ACC: Error Exporting to Existing Paradox or dBASE Tables (99944)



The information in this article applies to:

  • Microsoft Access 1.0
  • Microsoft Access 1.1
  • Microsoft Access 2.0
  • Microsoft Access for Windows 95 7.0
  • Microsoft Access 97

This article was previously published under Q99944
Moderate: Requires basic macro, coding, and interoperability skills.

SYMPTOMS

In Microsoft Access, you cannot export a Paradox or dBASE table over the top of an existing, corrupted Paradox or dBASE database file. If you try, you receive the following error message:
Table '<tablename>' already exists.

This error occurs with both dBASE and Paradox formats. Other database exports allow you to overwrite existing database files.

CAUSE

Microsoft Access tries to open the file to verify its contents instead of simply overwriting it.

STATUS

This behavior is by design.

MORE INFORMATION

Steps to Reproduce Behavior

In Microsoft Access 7.0 and 97:
  1. Create a new text file and save it as C:\My Documents\Config.dbf. This simulates a corrupted dBASE database.
  2. Start Microsoft Access and open the sample database Northwind.mdb.
  3. Select the Customers table in the Database window, and then click Save As/Export on the File menu.
  4. In the Save As dialog box, click To an External File or Database, and then click OK.
  5. In the Save Table 'Customers' In... dialog box, select dBASE III in the Save as type box.
  6. Type C:\My Documents\Config.dbf in the File name box, and then click Export.
  7. Click Yes to the "Do you want to replace the existing file?" message. Note that you receive the error message:
    Table 'config.dbf' already exists.
In Microsoft Access 1.x and 2.0:
  1. Create a new text file and save it as C:\Config.dbf. This simulates a corrupted dBASE database.
  2. Start Microsoft Access and open the sample database NWIND.MDB.
  3. On the File menu, click Export.
  4. In the Export dialog box, select dBASE III and then click OK.
  5. In the Select Microsoft Access Object dialog box, select Customers and then click OK.
  6. In the Export to File dialog box, type C:\Config.dbf in the File Name box, and then click OK.
  7. Click Yes to the "Do you want to replace it?" message. Note that you receive the error message:
    Table 'CONFIG#DBF' already exists.

Modification Type:MajorLast Reviewed:5/9/2003
Keywords:kbinterop kbprb KB99944