ACC: Error When Opening Attached Table in Shared .MDB File (99936)
The information in this article applies to:
- Microsoft Access 1.0
- Microsoft Access 1.1
- Microsoft Access 2.0
This article was previously published under Q99936 SYMPTOMS
When you attempt to open an attached table in a shared .MDB file, one
of the following error messages appears:
- Couldn't find file "<drive>:\<path>\<filename>"
- "<Drive>:\<path>\<filename>" isn't a valid path
- Couldn't open file "<drive>:\<path>\<filename>"
CAUSE
The path to an attached table is hard-coded in the table's properties.
For a shared .MDB file, this path is very likely invalid.
RESOLUTION
To work around this problem, either change the path to the attached
file so that it is valid, or import the data instead of attaching the
table.
To verify and correct the path for an attached table, use the
following procedure:
- Open the table in Design view.
- From the View menu, choose Table Properties. The Description
property contains the path to the attached table.
- Place the .MDB file and its attached tables on a share on a
dedicated server.
- Use one of the following two naming conventions:
- Choose a drive letter (for example, "u:") and make sure all
users connect to the share using that drive letter. Use the
same drive letter for the attached tables.
-or- - Use the universal naming convention (UNC) for the attached
tables (for example, \\<server>\<share>\<filename>).
NOTE: To attach a database using UNC, specify the UNC name and the
database name where you normally would specify the drive and database
names. For example, instead of logging on to the network drive,
typing the database name, and choosing Attach Table from the File
menu, you need only enter the UNC name and the database name in the
Attach dialog box, as follows:
\\MYSERVER\PUBLIC\MYDB.MDB
MORE INFORMATION
If the .MDB file is placed on a non-dedicated server that does not allow
redirecting to itself (for example, Microsoft Windows for Workgroups), you
must maintain two separate .MDB files, one to share with other workstations
and one for your local computer.
Maintaining two separate copies of the .MDB file is necessary because
Windows for Workgroups does not allow a server to redirect to itself. For
example, if the server name is SERVERNM, the SERVERNM computer cannot use
the path \\SERVERNM\SHARE to access a file from its own hard disk.
If the .MDB file is placed on a non-dedicated server that does allow
redirecting to itself (for example, Microsoft Windows NT), you only need to
maintain one .MDB file.
REFERENCES
For more information about Linking to tables in an external Access .MDB,
search the Help Index for "Attached Tables" and then "Import or Link data"
or ask the Microsoft Access 97 Office Assistant.
Modification Type: | Major | Last Reviewed: | 5/9/2003 |
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Keywords: | kbinterop kbprb KB99936 |
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