LAN Manager Bug Fix for Post Logon Script Delay (97495)
The information in this article applies to:
- Microsoft LAN Manager 2.0
- Microsoft LAN Manager 2.1
- Microsoft LAN Manager 2.1a
- Microsoft LAN Manager 2.2
This article was previously published under Q97495 SYMPTOMS
In LAN Manager, failure of a network request command during a logon script
from Windows would cause the script to pause a long time before returning
control to the user.
CAUSE
The problem arose from the way the timer was being kept. When a NET ERROR
occurred (for instance, a NET USE to a non-existent server) the Windows
procedure would not receive timer ticks, so it would introduce a delay
before ending the logon script window.
RESOLUTION
Microsoft has confirmed this to be a problem in LAN Manager versions 2.1a
and 2.2. This problem was corrected in the latest US Service Pack for LAN
Manager. The fix changed the logic to use a count to check for time elapsed
since the dialog was started and to abort the logon script based on this.
For information on obtaining this update, query on the following word in
the Microsoft Knowledge Base:
Modification Type: | Major | Last Reviewed: | 9/30/2003 |
---|
Keywords: | kbnetwork KB97495 |
---|
|