PRB: Video Card Causes GP Faults or Display Problems (95232)



The information in this article applies to:

  • Microsoft Visual FoxPro for Windows 3.0
  • Microsoft Visual FoxPro for Windows 5.0
  • Microsoft Visual FoxPro for Windows 6.0
  • Microsoft Visual FoxPro for Windows 7.0
  • Microsoft FoxPro for Windows 2.5
  • Microsoft FoxPro for Windows 2.5a
  • Microsoft FoxPro for Windows 2.5b
  • Microsoft FoxPro for Windows 2.6
  • Microsoft FoxPro for Windows 2.6a

This article was previously published under Q95232

SYMPTOMS

A number of video cards do not work properly with FoxPro for Windows. They may cause general protection (GP) faults or display problems.

CAUSE

FoxPro for Windows makes intensive use of screen input/output (I/O), which does not work well with some video cards. The following video cards have been identified as conflicting with FoxPro for Windows:
  • AST Power Premium 486 with VGA motherboard
  • ATI Ultra Graphics Pro (local bus)
  • COMPAQ QVision
  • Dell 486/20 with VGA on motherboard
  • Diamond Stealth64 video driver
  • Genoa 7900 MM card
  • Hercules Dynamite Power VESA with ET 4000 chipset
  • MACH32
  • MATROX MGA video driver using 1024 x 768 resolution
  • NEC 2A
  • Oak VGA card with 640 x 480 x 256 colors for 286 or higher processor
  • Orchid Fahrenheit 1280 card using Microsoft Windows version 3.1
  • Speed Star 24x
  • TIGA 1024 x 768 x 256 small fonts
  • Trident 8900C
  • Number 9 Reality 332 video card with Hawkeye driverNOTE: The video cards discussed here are manufactured by vendors independent of Microsoft; we make no warranty, implied or otherwise, regarding these products' performance or reliability.

RESOLUTION

To test the compatibility of the video card being used and FoxPro for Windows, use one of the standard Windows drivers that ships with Windows, for example, the VGA or Super VGA driver. If the problem no longer occurs when you are using the standard Windows video driver, contact the vendor for an updated version of the video driver or obtain the proper driver from the Windows Driver Library (WDL). (See the MORE INFORMATION section for information on obtaining a WDL driver.)

STATUS

This behavior is by design.

MORE INFORMATION

The WDL drivers are available at no charge from the Microsoft Software Library and the Internet. However, note that standard connect-time fees and long-distance telephone charges, if any, still apply during downloading. When you connect to any of these services, please read the WDL.TXT file for downloading instructions and a complete list of devices supported in the WDL.

If you do not have a modem, you can obtain an individual WDL driver on disk by calling Microsoft Product Support at (425) 637-7098.

Other Bulletin Board Service (BBS) Numbers

The BBS number for Trident is (415) 691-1016.

Modification Type:MinorLast Reviewed:2/11/2005
Keywords:kb3rdparty kbprb KB95232