ACC: "Unable to Connect to Data Source" Error Message (1.x/2.0) (95012)



The information in this article applies to:

  • Microsoft Access 1.0
  • Microsoft Access 1.1
  • Microsoft Access 2.0

This article was previously published under Q95012

SYMPTOMS

Advanced: Requires expert coding, interoperability, and multiuser skills.

When you try to gain access to a SQL Server, you may receive the following error message:
Unable to connect to data source

CAUSE

The SQL Server you are trying to gain access to does not have a correct entry in the [SQLSERVER] section of the WIN.INI file or the SQL server is down, overloaded, or otherwise unavailable.

RESOLUTION

To correct this situation, verify that the SQL Server is up and available and that the entry in the [SQLSERVER] section of the WIN.INI file looks as follows:

   [SQLSERVER]
   MY_SERVER=DBNMP3,\\MY_SERVER\PIPE\SQL\QUERY
				


If there are any spaces in this entry or if the server name in the \\MY_SERVER\PIPE\SQL\QUERY part of the statement is misspelled, you will receive the error message.

MORE INFORMATION

It is possible that there are other situations which may indirectly cause this error message. Here are several other things you can check to troubleshoot this problem:
  • Use File Manager to search for multiple, corrupted, or outdated copies of these files:

    ODBC.DLL - 44736 bytes, dated 10-16-92 or later
    DBNMP3.DLL - 8241 bytes, dated 9-15-92 or later
    SQLSRVR.DLL - 135792 bytes, dated 10-16-92 or later
    NETAPI.DLL - depends on the network being used
    COMMDLG.DLL - 89248 bytes, dated 10-25-92 or later

    NOTE: The sizes and dates referenced are correct if the files were installed by Microsoft Access version 1.0.
  • Make sure the files listed above are in appropriate locations. All files except NETAPI.DLL are usually installed in the Windows System directory. The NETAPI.DLL file is a network specific driver, so it's usually located in the network's program directory, which should be in the path.
  • Use another application, such as Q+E, SAF, or PowerBuilder, on the same computer to attempt to attach to the same data source. If you cannot access the data source from another application, there is probably a problem with the network (NETAPI.DLL) or with the server, not with Microsoft Access or ODBC.
  • Attempt to attach to another data source, if available, such as another SQL server. If you can attach to another server, then the original server may be down or you may need to reconfigure the entry for that server using the ODBC Administration Utility.
  • Attempt to attach to the same data source from another computer. If you cannot access the SQL server from another computer, there may be a network wide problem or the server may be down or not communicating.
  • Try increasing the ODBC timeout settings in the ODBC section of the MSACCESS.INI file.
  • Check with the system administrator to see if the SQL server is up, available for transactions, and operating correctly.
  • Reinstall ODBC after performing a clean boot and renaming the ODBC.DLL, DBNMP3.DLL, and SQLSRVR.DLL files.

REFERENCES

Microsoft Access "User's Guide," version 1.0, Appendix D, "Setting Up Microsoft Access on a Network," pages 660-662

Modification Type:MajorLast Reviewed:5/9/2003
Keywords:kberrmsg kbprb kbusage KB95012