ACC: Empty Table List When Attaching Btrieve Table (94828)
The information in this article applies to:
- Microsoft Access 1.0
- Microsoft Access 1.1
- Microsoft Access 2.0
This article was previously published under Q94828
Moderate: Requires basic macro, coding, and interoperability skills.
SYMPTOMS
When you attach a Btrieve table, you select the Xtrieve dictionary file
(FILE.DDF) in the Select File box. When you choose OK, Microsoft Access
opens the dictionary file and displays a list of tables you can import or
attach. However, the list is empty. In Microsoft Access version 2.0, you
may receive the error message:
Btrieve: Can't find file FIELD.DDF
CAUSE
You do not have the FIELD.DDF file that Microsoft Access requires to attach
a Btrieve table.
RESOLUTION
Microsoft Access requires the following three .DDF files in order to attach
a Btrieve table: FILE.DDF, INDEX.DDF, and FIELD.DDF. Make sure that you
have all three .DDF files before you try to attach a Btrieve table.
MORE INFORMATION
When Microsoft Access cannot find the FIELD.DDF file, it creates a
6144-byte dummy FIELD.DDF file in the same directory in which FILE.DDF
appears. If you find this dummy file, you know that you are missing the
required FIELD.DDF file. Use Xtrieve or another third-party utility to
create the required .DDF files.
Btrieve and Xtrieve are manufactured by Pervasive Software, a vendor
independent of Microsoft; we make no warranty, implied or otherwise,
regarding these products' performance or reliability.
Modification Type: | Major | Last Reviewed: | 5/9/2003 |
---|
Keywords: | kb3rdparty kberrmsg kbprb KB94828 |
---|
|