ACC: Expression Error May Be Caused by International Setting (94825)
The information in this article applies to:
- Microsoft Access 1.0
- Microsoft Access 1.1
- Microsoft Access 2.0
- Microsoft Access for Windows 95 7.0
- Microsoft Access 97
This article was previously published under Q94825 Novice: Requires knowledge of the user interface on single-user computers.
SYMPTOMS
When you try to enter an expression that requires a list separator in the
QBE grid field or criteria rows, or as the ControlSource property setting
for a text box in a form or report, the attempt fails, and you may receive
the following error message:
In Microsoft Access 7.0 and 97:
The expression you entered has invalid syntax.
In Microsoft Access 1.x and 2.0:
Syntax error
When you try to enter an expression that requires a list separator in an
action argument for a macro action, the attempt fails, and you may receive
the following error message:
In Microsoft Access 7.0 and 97:
Microsoft Access can't parse the expression: '<Expression>'
In Microsoft Access 1.x and 2.0:
Can't parse expression: '<Expression>'
CAUSE
In Microsoft Access 7.0 and 97, these errors can occur because of an
incorrect list separator setting on the Number tab of the Regional
Settings Properties dialog box in the Windows 95 or Windows NT 4.0 Control
Panel.
In Microsoft Access 1.x and 2.0, these errors can occur because of an
incorrect "slist" parameter setting in the [intl] section of the Windows
3.x Win.ini file. This setting specifies the character used to separate
items in a list. In United States English, the most common list separator
is a comma (,).
RESOLUTION
In Microsoft Access 7.0 and 97, follow these steps:
- In Microsoft Windows 95 or Windows NT 4.0, double-click the Regional
Settings icon in Control Panel.
- In the Regional Settings Properties dialog box, click the Regional
Settings tab. Note that you can select many different regions of the
world from the combo box.
- Click the Number tab and specify the correct list separator in the List
Separator box.
In Microsoft Access 1.x and 2.0:
There are three methods to address this situation, as follows:
- Use Windows Control Panel to modify the list separator in your Win.ini
file. Choose International from the Settings menu. Specify the correct
separator in the List Separator field.
- Use a text editor to modify the list separator in your Win.ini
file.
- Modify the expression so that it uses the list character specified in
your Win.ini file.
Modification Type: | Major | Last Reviewed: | 5/9/2003 |
---|
Keywords: | kberrmsg kbprb kbusage KB94825 |
---|
|