ACC: "Couldn't Update; (or Delete) Currently Locked by User" (94080)
The information in this article applies to:
- Microsoft Access 1.0
- Microsoft Access 1.1
- Microsoft Access 2.0
This article was previously published under Q94080
Moderate: Requires basic macro, coding, and interoperability skills.
SYMPTOMS
The following message appears either when two users simultaneously try to
update or delete a similar object in a shared database or on a single-user
system if the system runs out of locks:
Couldn't update; currently locked by user '<user name>' on machine
'<machine name>'
CAUSE
On a multiuser system, a conflict exists with the SYSTEM.MDA file. By
design, Microsoft Access cannot simultaneously update the MsysObjects
table in the SYSTEM.MDA file for multiple users.
On a single-user system, there are not enough locks specified in the
AUTOEXEC.BAT file.
NOTE: The .MDA file should not have the same name as .mdb file unless they
are in different directories.
RESOLUTIONMultiuser System
On a multiuser system, try saving the object again. If no one is updating
a similar object at the same time, the Save command should work. This
error can occur in Access Basic code also; therefore, you will need to
handle error trapping for this.
Single-User System- Quit Windows.
- Delete all the .LDB files from the Microsoft Access directory.
- Delete all the .TMP files from the Windows directory and from the
WINDOWS\TEMP directory.
- Edit the AUTOEXEC.BAT file. Look for a line similar to:
C:\DOS\SHARE.EXE
Add "/L:500" (without the quotation marks) to the end of the line, so
that it reads:
C:\DOS\SHARE.EXE /L:500
Note that this line will not be present if you run VSHARE.EXE, OS/2,
or you are running on a network.
- After saving the AUTOEXEC.BAT file, restart your computer.
Modification Type: | Major | Last Reviewed: | 5/9/2003 |
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Keywords: | kberrmsg kbprb kbusage KB94080 |
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