You cannot create a volume that is larger than 2 terabytes and that is smaller than 2.4 terabytes in Windows Unified Data Storage Server 2003 (925475)



The information in this article applies to:

  • Microsoft Windows Unified Data Storage Server 2003 Enterprise Edition x32
  • Microsoft Windows Unified Data Storage Server 2003 Enterprise Edition x64
  • Microsoft Windows Unified Data Storage Server 2003 Standard Edition x32
  • Microsoft Windows Unified Data Storage Server 2003 Standard Edition x64

SYMPTOMS

When you use Storage Manager in Microsoft Windows Unified Data Storage Server 2003 to create a volume that is larger than 2 terabytes and that is smaller than 2.4 terabytes, the storage wizard does not successfully create the volume.

CAUSE

This problem occurs because of a bug in the Storagemgmt.dll file.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix. However, you must close and then reopen Storage Manager or any open Microsoft Management Console (MMC).

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Unified Data Storage Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Storagemgmt.dll5.2.3790.27931,204,22415-Sep-200621:35x86
Windows Unified Data Storage Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Storagemgmt.dll5.2.3790.27931,204,22415-Sep-200622:00x86

WORKAROUND

To work around this problem, use either of the following methods:
  • When this problem occurs, the storage wizard does not successfully create the volume. However, the logical unit number (LUN) is successfully created. Therefore, you can use Disk Management to create the volume. To start Disk Management, click Start, click Run, type diskmgmt.msc, and then click OK.
  • Create a volume that is larger than 2.4 terabytes.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates



Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Microsoft Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:9/26/2006
Keywords:kbWinXPpreSP3fix kbfix kbBug kbHotfixServer kbQFE kbprb kbExpertiseInter KB925475 kbAudOEM