If you repeatedly press PRINT SCREEN, Windows XP may stop responding (924961)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Professional

SYMPTOMS

When you try to print the contents of the screen for a console application that is running in full-screen mode in Microsoft Windows XP, nothing is printed. If you repeatedly press PRINT SCREEN, Windows XP may stop responding. You may have to restart the computer.

CAUSE

This problem occurs because the Win32K.sys file does not release the bitmap that is stored in the clipboard when you press PRINT SCREEN. Eventually, this memory leak causes the computer to stop responding.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Windows XP Service Pack 2 (SP2)

Restart information

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix is not replaced by any later hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.1.2600.29941,839,74412-Sep-200609:41x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:10/5/2006
Keywords:kbWinXPpreSP3fix kbHotfixServer kbprb kbQFE kbfix KB924961 kbAudEndUser