Internet Explorer may lose its Favorites menu intermittently on a Windows 2000-based computer (924628)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

Microsoft Internet Explorer may lose its Favorites menu intermittently. This problem occurs if the following conditions are true:
  • You use a Microsoft Windows 2000-based computer that is running Internet Explorer 6.
  • You use a network shared folder as the Internet Explorer Favorites folder.
  • You configure this network shared folder as Offline Available.
  • You add a file to the Favorites folder during a period when the network is unavailable. This step modifies the Offline File cache.
When this problem occurs, the registry subkey for the Favorites menu resets to point to the %windir%\Favorites folder.

Note The Favorites menu uses the following registry subkey:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders\Favorites

CAUSE

This problem occurs because Client-Side Cache (CSC) Offline Sync Manager denies access to the shared folder when the network is unavailable. When the CSC Offline Sync Manager denies access, it synchronizes the folder content in the local cache from the server.

WORKAROUND

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To work around this problem, reset the Favorites folder. To do this, follow these steps:
  1. Restore the computer network connection.
  2. Exit Internet Explorer 6.
  3. Click Start, click Run, type regedit, and then click OK.
  4. Locate and then click the following registry subkey:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

  5. Right-click Favorites, and then click Modify.
  6. In the Value data box, type %USERPROFILE%\Favorites, and then click OK.
  7. Restart Internet Explorer 6.
Note If you configure the Favorites folder by using a logon script, you can log off the system, and then log back on to resolve the problem.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

The CSC Offline Sync Manager denies access to a shared folder when this shared folder is synchronizing with a computer that is running one of the following operating systems:
  • Windows 2000
  • Microsoft Windows XP
  • Microsoft Windows Server 2003
  • Window Server 2003 R2
The Favorites folder changes to %windir%\Favorites only on a Windows 2000-based computer. The other operating systems do not change the Favorites folder.

For more information about the Internet Explorer 6, visit the following Microsoft Web site:

Steps to reproduce the problem

  1. Configure Internet Explorer to use a Universal Naming Convention (UNC) network shared folder as the Favorites folder.
  2. Configure the UNC network shared folder as Offline File. To do this, follow these steps:
    1. Locate the UNC network shared folder.
    2. Click Tools, and then click Folder Options.
    3. Click the Offline Files tab, and then make sure that the following options are selected:
      • Enable Offline Files
      • Synchronize all offline files when logging on
      • Synchronize all offline files
  3. Add a Web page to the Favorites folder.
  4. Log off, and then disconnect from the network.
  5. Use cached credentials to log on to the system.
  6. Access the UNC network shared folder, and then put at least 10 megabytes (MB) of data in the shared folder.
  7. Log off, and then restore the network connection.
  8. Log on, and then wait for the CSC Offline Sync Manager to finish synchronizing data.
  9. Click Favorites to verify that the content has changed.
  10. Click Start, click Run, type regedit, and then click OK.
  11. Locate and then click the following registry subkey:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    The registry subkey points to the %windir%\Favorites folder.

Modification Type:MajorLast Reviewed:9/5/2006
Keywords:kbtshoot kbprb KB924628 kbAudEndUser kbAudITPRO