You cannot send e-mail messages to Exchange 2003 X.400 recipients when the X.400 address does not contain a trailing semicolon (924416)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Service Pack 2

SYMPTOMS

Consider the following scenario in Microsoft Exchange Server 2003 Service Pack 2 (SP2):
  • You create or import X.400 addresses in the Active Directory directory service.
  • Some of the addresses contain user names that have the same first name and last name. Additionally, the user names are distinguished only by an initial. For example, the user names may resemble Jane Doe and Jane A Doe.
  • The X.400 addresses do not contain a trailing semicolon. For example, the X.400 addresses may resemble [X400:C=US;A= ;P=MYORG;S=Doe;G=Jane] instead of [X400:C=US;A= ;P=MYORG;S=Doe;G=Jane;].
In this scenario, you receive a non-delivery report (NDR) that resembles the following when you try to send an e-mail message to either recipient:
The e-mail account does not exist at the organization this message was sent to. Check the e-mail address, or contact the recipient directly to find out the correct address. <SERVERNAME.DOMAIN.com #5.1.1>

CAUSE

This problem occurs if the Exchange 2003 message transfer agent (MTA) tries to match the recipient address by using the Given Name and Surname attributes. When two or more X.400 addresses share the same Given Name and Surname attributes, and the X.400 addresses do not contain a trailing semicolon, an NDR report is generated.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Exchange 2003 SP2 must be installed before you apply this hotfix.

Restart requirement

The Microsoft Exchange Message Transfer Agent (MTA) service is restarted when you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Emsmta.exe6.5.7651.483,597,31208-Sep-200616:35x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information about the naming schema for Exchange Server software updates, click the following article number to view the article in the Microsoft Knowledge Base:

817903 New naming schema for Exchange Server software update packages


Modification Type:MajorLast Reviewed:9/19/2006
Keywords:kbQFE kbfix kbBug kbhotfixserver kbpubtypekc KB924416 kbAudITPRO