A Systems Management Server (SMS) 2003 client computer stops responding when you try to perform a software update scan of the Inventory Tool for Microsoft Updates (ITMU) on a computer that is running SMS 2003 with Service Pack 1 (924148)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

You try to perform a software update scan of the Inventory Tool for Microsoft Updates (ITMU) tool on a computer that is running Microsoft System Management Server (SMS) 2003 with Service Pack 1 (SP1). When you do this, the SMS 2003 client computer stops responding. Additionally, you notice a 100 percent CPU usage when you try to perform the software update scan of the ITMU tool.

CAUSE

This problem occurs because some relationships among updates are affecting the Windows Update Agent performance when you perform the software update scan of the ITMU tool. These relationships among updates are authored into the Wsusscan.cab file.

Note The software update scan of the ITMU tool is a CPU-intensive operation. However, the 100 percent CPU usage is not a problem until the SMS 2003 client computer stops responding.

RESOLUTION

To resolve this problem, synchronize the latest Wsusscan.cab with your ITMU scan package. The updated Wsusscan.cab file has a digital signature time stamp on or after the following date and time:

Thursday, August 24, 2006, 10:27:58 A.M.

To view the digital signature time stamp of the updated Wsusscan.cab file, follow these steps:
  1. Right-click the updated Wsusscan.cab file, and then click Properties.
  2. In the Wsusscan.cab Properties dialog box, click the Digital Signatures tab, and then view the time stamp property.

MORE INFORMATION

Any future performance improvements will be referenced by this Microsoft Knowledge Base article.

Additional best practices include the following:
  • Whenever possible, schedule updates on managed client computers outside business hours.
  • When you try to deploy updates, we recommend that you send out an advertisement that is configured to let the end-users know that updates are currently being applied.
  • Schedule updates on managed servers when the server usage is low.
The ITMU tool was released in 2005 and is designed to help customers update managed systems. The ITMU tool replaces many legacy scan tools with a single scan tool. The ITMU tool shares the same security update, update rollup, and service pack data as offered by Microsoft Windows Server Update Services (WSUS). This ITMU tool can be used only in an SMS 2003 Service Pack 2 (SP2) site hierarchy or in an SMS 2003 SP1 site hierarchy that has certain hotfixes applied.

Modification Type:MajorLast Reviewed:10/10/2006
Keywords:kbprb KB924148 kbAudITPRO