Error messages when you try to open the Virtual Server 2005 Administration Web site: "LsaRegisterLogonProcess() failed! Access is denied" or "CAccessToken::GetProcessToken() failed! Access is denied" (923833)



The information in this article applies to:

  • Microsoft Virtual Server 2005

SYMPTOMS

After you upgrade from Microsoft Virtual Server 2005 to Microsoft Virtual Server 2005 R2, you may receive one or both of the following error messages when you try to open the Virtual Server 2005 Administration Web page:
LsaRegisterLogonProcess() failed! Access is denied
CAccessToken::GetProcessToken() failed! Access is denied

CAUSE

This issue occurs if the security account for the virtual server application pool in Microsoft Internet Information Services (IIS) is using the Network Service account. Then, when you install Virtual Server 2005 R2, the Virtual Server 2005 Web site is configured to run by using the Local System account.

WORKAROUND

To work around this issue, you must make the security account for the virtual server application pool use the Local System account in IIS Manager. To do this, follow these steps:
  1. Log on to the computer that is running Virtual Server 2005 by using an account that has administrative permissions.
  2. Click Start, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
  3. Expand Application Pools, right-click the virtual server application pool, and then click Properties.
  4. Click the Identity tab, click the list next to Predefined, click Local System, and then click OK.

Modification Type:MinorLast Reviewed:9/13/2006
Keywords:kbprb KB923833 kbAudITPRO