FIX: The backup application stops responding when you perform a backup that uses a volume snapshot in Windows Server 2003 with SP1 (923628)



The information in this article applies to:

  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Web Edition
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Datacenter Edition
    • Microsoft Windows Server 2003, Standard x64 Edition
    • Microsoft Windows Server 2003, Enterprise x64 Edition
    • Microsoft Windows Server 2003, Datacenter x64 Edition
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems

SYMPTOMS

When you perform a backup in Microsoft Windows Server 2003 with Service Pack 1 (SP1), the backup application stops responding. This behavior occurs if the backup uses a volume snapshot.

CAUSE

This problem occurs because of an issue in the Volsnap.sys file. This issue generates a deadlock condition. In the deadlock condition, the system I/O is suspended. A file deletion operation is waiting for the system I/O to resume.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this update, you must have Microsoft Windows Server 2003 Service Pack 1 (SP1) installed on the computer. For more information about how to obtain Windows Server 2003 Service Pack 1, click the following article number to view the article in the Microsoft Knowledge Base:

889100 How to obtain the latest service pack for Windows Server 2003

Restart information

You must restart the computer after you apply this update.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Eventcls.dll5.2.3790.276231,23202-Aug-200617:45x86SP1
Ftdisk.sys5.2.3790.2762137,21602-Aug-200612:13x86SP1
Partmgr.sys5.2.3790.276225,08802-Aug-200612:41x86SP1
Swprv.dll5.2.3790.2762275,96802-Aug-200617:45x86SP1
Volsnap.sys5.2.3790.2762153,60002-Aug-200612:13x86SP1
Vssadmin.exe5.2.3790.2762134,14402-Aug-200612:13x86SP1
Vssapi.dll5.2.3790.2762561,66402-Aug-200617:45x86SP1
Vssui.dll5.2.3790.2762144,38402-Aug-200617:45x86SP1
Vssvc.exe5.2.3790.2762836,09602-Aug-200612:13x86SP1
Vss_ps.dll5.2.3790.276219,45602-Aug-200617:45x86SP1
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Eventcls.dll5.2.3790.276282,43202-Aug-200603:17IA-64SP1
Ftdisk.sys5.2.3790.2762498,68802-Aug-200603:17IA-64SP1
Partmgr.sys5.2.3790.276283,45602-Aug-200603:17IA-64SP1
Swprv.dll5.2.3790.2762832,51202-Aug-200603:17IA-64SP1
Volsnap.sys5.2.3790.2762476,16002-Aug-200603:17IA-64SP1
Vssadmin.exe5.2.3790.2762313,85602-Aug-200603:17IA-64SP1
Vssapi.dll5.2.3790.27621,640,44802-Aug-200603:17IA-64SP1
Vssui.dll5.2.3790.2762407,55202-Aug-200603:17IA-64SP1
Vssvc.exe5.2.3790.27622,586,11202-Aug-200603:17IA-64SP1
Vss_ps.dll5.2.3790.276231,23202-Aug-200603:17IA-64SP1
Wvssapi.dll5.2.3790.2762561,66402-Aug-200603:17x86SP1
Wvss_ps.dll5.2.3790.276219,45602-Aug-200603:17x86SP1
Windows Server 2003 x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Eventcls.dll5.2.3790.276246,08002-Aug-200603:11x64SP1
Ftdisk.sys5.2.3790.2762240,12802-Aug-200603:11x64SP1
Partmgr.sys5.2.3790.276245,05602-Aug-200603:11x64SP1
Swprv.dll5.2.3790.2762656,89602-Aug-200603:11x64SP1
Volsnap.sys5.2.3790.2762288,76802-Aug-200603:11x64SP1
Vssadmin.exe5.2.3790.2762245,24802-Aug-200603:11x64SP1
Vssapi.dll5.2.3790.27621,320,96002-Aug-200603:11x64SP1
Vssui.dll5.2.3790.2762233,47202-Aug-200603:11x64SP1
Vssvc.exe5.2.3790.27622,061,82402-Aug-200603:11x64SP1
Vss_ps.dll5.2.3790.276225,60002-Aug-200603:11x64SP1
Wvssapi.dll5.2.3790.2762561,66402-Aug-200603:11x86SP1
Wvss_ps.dll5.2.3790.276219,45602-Aug-200603:11x86SP1

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:9/6/2006
Keywords:kbHotfixServer kbPubTypeKC kbExpertiseAdvanced kbQFE kbfix kbWinServ2003preSP2fix KB923628 kbAudITPRO