FIX: The PDF file becomes corrupted after you check in the PDF file in Visual SourceSafe 2005 (923434)



The information in this article applies to:

  • Microsoft Visual SourceSafe 2005 Standard Edition

SYMPTOMS

After you check in a Portable Document Format (PDF) file in Microsoft Visual SourceSafe 2005, the PDF file becomes corrupted. Additionally, you do not receive any error messages. You may experience this problem if the following conditions are true:
  • You select the Auto-detect encoding of local file check box on the General tab.

    Note To access the General tab, click Properties on the File menu.
  • In the Options dialog box, you select Binary file on the File types tab.

    Note To open the Options dialog box, click Options on the Tools menu.

CAUSE

This problem occurs when the autodetect feature switches the file from the binary format to the ANSI format.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

There are no prerequisites for this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Ssapi.dll8.0.50727.194500,73611-Aug-200605:44x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:9/29/2006
Keywords:kbQFE kbhotfixserver kbpubtypekc KB923434 kbAudDeveloper kbAudITPRO