The tasks in Scheduled Tasks are no longer scheduled to run after you rename a Windows XP-based computer that is not in a domain (923423)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

You rename a Windows XP-based computer that is not in a domain. After you rename the computer, the tasks in Scheduled Tasks are no longer scheduled to run. This problem affects the existing scheduled tasks and also any tasks that you create in the future.

Note To open Scheduled Tasks, click Start, click Run, and then type control schedtasks.

CAUSE

The problem occurs because the Windows XP-based computer executes a task based on the credentials cache. When a task is created, the credentials that are used to run this task are cached at the same time. The credential cache uses the literal computer name. The computer name information in the credentials cache is not updated when you rename the Windows XP-based computer.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Schedsvc.dll5.1.2600.2975192,51216-Aug-200611:53x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:9/26/2006
Keywords:kbQFE kbhotfixserver kbpubtypekc KB923423 kbAudITPRO kbAudEndUser