A Windows XP-based computer is not detected by IEEE 1394 devices that use the HANA specification (923404)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

SYMPTOMS

Consider the following scenario:
  • You connect a device to a Microsoft Windows XP-based computer by using an Institute of Electrical and Electronics Engineering, Inc. (IEEE) 1394 (FireWire) connection.
  • The device uses the High Definition Audio-Video Network Alliance (HANA) specification.
In this scenario, the connected IEEE 1394 device does not recognize the computer. For example, a connected TV that uses the HANA specification shows other connected IEEE 1394-based devices on the screen. However, the connected Windows XP-based computer is not listed.

CAUSE

The problem occurs because of a bug in the Windows XP IEEE 1394 bus driver (1394bus.sys).

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
1394bus.sys5.1.2600.297453,37614-Aug-200611:19x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:9/5/2006
Keywords:kbWinXPsp3fix kbWinXPpreSP3fix kbHotfixServer kbQFE kbExpertiseBeginner KB923404 kbAudEndUser