Event messages are truncated when you have more than 10 disks installed on a Windows Server 2003-based computer (923356)



The information in this article applies to:

  • Microsoft Windows Server 2003 Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
  • Microsoft Windows Server 2003 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Web Edition

SYMPTOMS

Consider the following scenario. On a Microsoft Windows Server 2003-based computer, you have more than 10 disks installed. Additionally, one of the disks contains a bad block. This bad block generates an event message. However, a key element in the event message is truncated.

For example, an event message that resembles the following appears in the System log:
The device, \Device\Harddisk1, has a bad block.
This event message should appear as follows:
The device, \Device\Harddisk12, has a bad block.
Notice that "\Device\Harddisk12" is truncated to "\Device\Harddisk1." Therefore, you cannot determine which disk is generating the problem.

This problem occurs in the event ID 7 and event ID 11 messages.

Note This problem does not occur on Microsoft Windows Vista-based systems.

CAUSE

This problem occurs because the size of the logged data, together with the driver name and the device name, is larger than the size of the port message. Therefore, event ID messages are truncated at the end of the message data.

RESOLUTION

To resolve this problem, use hardware diagnostics, or contact your hardware vendor.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MajorLast Reviewed:8/14/2006
Keywords:kberrmsg kbtshoot kbprb KB923356 kbAudITPRO