Error message when you perform a full backup of a database in SQL Server 2005: "Backup failed for Server 'ComputerName\SQLInstanceName' " or "The backup of the file or filegroup 'sysft_FullTextCatalog' is not permitted because it is not online" (923355)



The information in this article applies to:

  • Microsoft SQL Server 2005 Standard Edition
  • Microsoft SQL Server 2005 Workgroup
  • Microsoft SQL Server 2005 Developer Edition
  • Microsoft SQL Server 2005 Enterprise Edition

Bug #: 432932 (SQLBUDT)

SYMPTOMS

When you perform a full backup of a database in Microsoft SQL Server 2005, you may receive an error message that resembles the following:
Backup failed for Server 'ComputerName\SQLInstanceName'. (Microsoft.SqlServer.Smo)

Additional information:
System.Data.SqlClient.SqlError: The backup of the file or filegroup "sysft_ FullTextCatalog" is not permitted because it is not online. BACKUP can be performed by using the FILEGROUP or FILE clauses to restrict the selection to include only online data. (Microsoft.SqlServer.Smo)
If you perform a full backup of a database in SQL Server 2005 Service Pack 2 (SP2), you may receive an error message that resembles the following:
The backup of full-text catalog 'FullTextCatalog' is not permitted because it is not online. Check errorlog file for the reason that full-text catalog becomes offline and bring it online. Or BACKUP can be performed by using the FILEGROUP or FILE clauses to restrict the selection to include only online data.

CAUSE

This behavior occurs because a full-text catalog in the database is not online. To perform a full backup, SQL Server 2005 requires all the database files and full-text catalogs in the database to be online.

The full-text catalog may be online because one or more of the following conditions are true:
  • The full-text catalog folder is either deleted or corrupted.
  • You did not enable the database for full-text indexing.
  • The database is restored from a Microsoft SQL Server 2000 database backup. Therefore, the folder of the full-text catalog in the database does not exist on the server where you restore the database.
  • The instance of SQL Server 2005 that you are running was upgraded from SQL Server 2000. However, the full-text search service cannot be accessed during the upgrade.
  • The database is attached from somewhere. However, you specify the incorrect location for the full-text catalog folder during the attachment.

WORKAROUND

To work around this behavior, follow these steps:
  1. Locate the folder that contains the files for the problematic full-text catalog.
  2. Run the ALTER DATABASE statement. Specify in the statement the correct location for the full-text catalog.

    For more information about how to use the ALTER DATABASE statement in this scenario, visit the following Microsoft Developer Network (MSDN) Web site, and then search for the "Moving Full-Text Catalogs" topic:
  3. Rebuild the problematic full-text catalog in the database.
  4. Perform a full backup of the database in SQL Server 2005 again.
Notes
  • If you have not enabled the database for full-text indexing, you must enable this option first before you can perform a full backup of the database in SQL Server 2005.

    For more information about how to enable a database for full-text indexing in SQL Server 2005, visit the following MSDN Web site:
  • If you do not need the full-text catalog any longer, you can drop the problematic full-text catalog. Then, perform a full backup of the database in SQL Server 2005.

STATUS

This behavior is by design.

MORE INFORMATION

Steps to reproduce the behavior

  1. In SQL Server 2005, create a full-text catalog.
  2. Stop the full-text search service.
  3. Kill the full-text search process in Windows Task Manager if the process exists.
  4. Delete the full-text catalog folder. The full-text catalog folder is located in the following folder:

    %ProgramFiles%\Microsoft SQL Server\MSSQL.1\MSSQL\FTData

  5. Start the full-text search service.
  6. Perform a full back of the database that contains the full-text catalog.

Modification Type:MajorLast Reviewed:8/8/2006
Keywords:kbsql2005fts kbExpertiseAdvanced kbtshoot kbprb KB923355 kbAudDeveloper kbAudITPRO