FIX: The client connections are dropped frequently when you use the IPsec tunnel through a NAT device on a Windows Server 2003 Service Pack 1-based server (923339)



The information in this article applies to:

  • Microsoft Windows Server 2003 SP1

SYMPTOMS

When you use the Internet Protocol security (IPsec) tunnel through a Network Address Translator (NAT) device in Windows Server 2003 Service Pack 1 (SP1), the client connections may be dropped frequently from the Windows Server 2003 SP1-based server. This issue may occur soon after the client connects to the server.

CAUSE

This issue occurs because the IPsec driver does not update the LastUsed timestamp for the IPsec tunnel in Windows Server 2003 SP1. This causes the connection to be dropped during IPsec Quick Mode (QM) renegotiation even though the tunnel is never idle.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 SP1 installed on the computer.

Restart information

You do not have to restart your computer after you apply this hotfix.

Registry information

You do not have to change the registry.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

Hotfix file information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003, x86-based versions with Service Pack 1

File nameFile versionFile sizeDateTimePlatform
Ipsec.sys5.2.3790.275982,43228-Jul-200610:19x86

Windows Server 2003, x64-based versions with Service Pack 1

File nameFile versionFile sizeDateTimePlatform
Ipsec.sys5.2.3790.2759155,13627-Jul-200622:52x64

Windows Server 2003, Itanium-based versions with Service Pack 1

File nameFile versionFile sizeDateTimePlatform
Ipsec.sys5.2.3790.2759257,53627-Jul-200622:52IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:8/22/2006
Keywords:kbtshoot kbWinServ2003preSP2fix kbExpertiseAdvanced kbfix kbQFE kbhotfixserver kbpubtypekc KB923339 kbAudITPRO