FIX: EAP reauthentication may not occur and the Wireless Zero Configuration service may not work correctly when you try to use a third-party application in Windows XP (923154)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition SP2
  • Microsoft Windows XP Professional SP2

SYMPTOMS

When you try to use a third-party application that uses the Extensible Authentication Protocol (EAP) in Microsoft Windows XP, EAP reauthentication may not occur when it is required. Additionally, the Wireless Zero Configuration service in Windows XP may not work correctly. This problem may continue to occur after you restart the Wireless Zero Configuration service.

Note This problem may occur when you use Windows XP or Windows XP with Service Pack 2.

CAUSE

This problem occurs because the third-party application is configured to wait approximately 45 seconds before EAP reauthentication occurs. When the application is configured in this manner, EAP reauthentication may stop occurring after a random period of time. Additionally, the Wireless Zero Configuration service may not display any message for you to approve a reauthentication process.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

There are no prerequisites for installing this hotfix.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

Hotfix file information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Ndisuio.sys5.1.2600.297914,59222-Aug-200608:53x86SP2SP2QFE
Netshell.dll5.1.2600.29791,705,47222-Aug-200612:32x86SP2SP2QFE
Wzcdlg.dll5.1.2600.2979383,48822-Aug-200612:32x86SP2SP2QFE
Wzcsapi.dll5.1.2600.297952,73622-Aug-200612:32x86SP2SP2QFE
Wzcsvc.dll5.1.2600.2979476,16022-Aug-200612:32x86SP2SP2QFE
Xpsp3res.dll5.1.2600.2979210,94422-Aug-200608:45x86SP2SP2QFE
Updspapi.dll6.2.29.0371,42412-Oct-200523:12x86NoneNot Applicable

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:9/7/2006
Keywords:kbfix kbQFE kbhotfixserver kbpubtypekc KB923154 kbAudDeveloper