You may receive an error message when you try to start a counter log by using the Performance Logs and Alerts tool in Windows XP Service Pack 2 (923118)



The information in this article applies to:

  • Microsoft Windows XP Service Pack 2
  • Microsoft Windows XP Home Edition SP2
  • Microsoft Windows XP Professional SP2

SYMPTOMS

When you try to start a counter log by using the Performance Logs and Alerts tool in Microsoft Windows XP Service Pack 2 (SP2), you may experience any of the following symptoms:
  • You may receive the following error message:
    The LogName log or alert has not started. Refresh the log or alert list to view current status, or see the application event log for any errors.
    Note LogName is the name of the log that you tried to start.
  • The following warning message may be reported in the Windows Application log:
    Event ID: 2029 The service was unable to add any counters to the LogName log or alert. The log or alert will not be started.
  • Data is missing from the new counter log.
This problem occurs when you use a non-English version of Windows XP.

CAUSE

This problem may occur if the name of the log that you tried to start contains one or more wildcard characters. Wildcard characters in counter log names are not correctly parsed by non-English versions of Windows XP. When this occurs, counters are not added to the log.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack for Microsoft Windows XP that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Prerequisites

The following list contains prerequisites for the hotfix:
  • Microsoft Windows XP Service Pack 2

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File nameFile versionFile sizeDateTimePlatform
Smlogsvc.exe5.1.2600.295889,60022-Jul-200611:07x86
Updspapi.dll6.2.29.0371,42412-Oct-200523:12x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:9/8/2006
Keywords:kbfix kbQFE kbhotfixserver kbpubtypekc KB923118 kbAudDeveloper