Error message when you restart a computer that is running Windows XP Professional: "Stop 0xC000021A" (922410)



The information in this article applies to:

  • Microsoft Windows XP Professional

SYMPTOMS

When you restart a computer that is running Microsoft Windows XP Professional, you may randomly receive the following error message:
Stop 0xC000021A
Note You may experience this problem more frequently if Group Policy is applied immediately before the computer is restarted.

This problem occurs if the Winlogon.exe program crashes during the Windows startup process. In this situation, a "Stop 0xC000021A" error message occurs.

CAUSE

This problem occurs if the Wbemprox.dll library is unloaded prematurely. In this situation, the Component Object Model (COM) proceeds with the unload operation because the following conditions are true:
  • COM does not detect that a particular thread is still using COM.
  • The particular thread has the Wbemprox.dll library on its call stack.
This problem occurs because the Userenv.dll library does not call the CoInitialize function on the particular thread.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Because of file dependencies, you must be running Windows XP Service Pack 2 (SP2) to apply this hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Userenv.dll5.1.2600.2942724,99230-Jun-200622:33x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:8/29/2006
Keywords:kbWinXPpreSP3fix kbfix kbbug kbQFE kbhotfixserver kbpubtypekc KB922410 kbAudEndUser kbAudITPRO