You cannot locate contacts when you try to use the "Search" or the "Look For" feature in Outlook to locate contacts in Exchange Server 2003 (922250)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition

SYMPTOMS

You try to use the Search or the Look for feature in Microsoft Outlook to locate contacts in Public Folders in Microsoft Exchange Server 2003. When you do this, you cannot locate contacts. Alternatively, you locate only a partial list of contacts.

If you use the Advanced Find feature in Outlook, you can locate contacts in Public Folders.

CAUSE

This issue occurs if one or more of the contacts are malformed or corrupted. When the Search or the Look for feature locates one of the corrupted contacts, the search process stops without warning.

RESOLUTION

To resolve this issue, use one of the following methods.

Method 1: Export and then import the contacts

The "export to text" format can correct bad data or incorrect attribute settings under certain circumstances. To use the "export to text" format, follow these steps:
  1. In Outlook, create a new folder named CON2 in the mailbox. Then, copy the contacts from Public Folders to the CON2 folder. To do this, follow these steps:
    1. Right-click the mailbox name, and then click New Folder.
    2. In the Name box, type CON2.
    3. In the Folder Contains list, click Contact Items, and then click OK.
    4. Right-click the contacts in Public Folders, and then click Copy "Contacts".
    5. In the Copy the selected folder to the folder list, click CON2, and then click OK.
  2. On the File menu, click Import and Export.
  3. In the Import and Export wizard, click Export to a file, and then click Next.
  4. Click Comma Separated Values (Windows), and then click Next.
  5. In the Select folder to export from list, click CON2, and then click Next.
  6. In the Save exported file as box, type the path in which you want to save the file and the file name that you want to use.
  7. Click Finish.

    Note Make sure that you export all the contacts from the CON2 folder. There may be filters or custom views that are assigned to the contact folder. These filters or custom views may prevent you from seeing all the items that the folder contains.
  8. After the contacts are exported to the .csv text format file (Windows .CSV), delete the contacts in the CON2 folder.
  9. Import the contacts from the .csv file to the CON2 folder.
  10. Delete the original contacts from the contacts folder in Public Folders.
  11. Copy the contacts from the CON2 folder to the original contacts folder in Public Folders.
  12. Delete the CON2 folder.
  13. Complete the Search or the Look for query to see whether Outlook returns all contacts that match the search criteria.

Method 2: Use the CheckType.exe tool

You can use the CheckType.exe tool to scan the contacts folder in Public Folders to determine whether any contacts are corrupted or malformed. We recommend that you use this method to resolve this issue. However, you must contact Microsoft Product Support Services to obtain the CheckType.exe tool.

Note This tool must be used by only the Exchange Server administrator.

For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve this issue. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

To use this method, you must also have an e-mail account that has owner rights to the public folder that is experiencing the issue. The owner of the public folder must re-create the contacts in the original contacts folder in Public Folders by using the correct data. To do this, follow these steps:
  1. On a workstation computer, save the CheckType.exe tool to a new folder that is named "CheckType." For example, save the tool to the following folder:

    C:\CheckType\CheckType.exe

  2. On the workstation computer, create an Outlook profile. Make sure that the account that you use to create the profile has owner rights to the public folder that is experiencing the issue.
  3. In Control Panel, click Mail, and then click Show Profiles.
  4. Click Prompt for a profile to be used, and then click OK.
  5. In Outlook, right-click Public Folders, and then click New Folder.
  6. In the Name box, type BadContacts.
  7. In the Folder Contains list, click Contact Items, and then click OK.
  8. Start a command prompt. To do this, click Start, click Run, type CMD, and then click OK.
  9. Type the following commands. Press ENTER after each command.

    CD C:\CheckType

    Checktype Top_Folder_Name%Your_Folder_Name%Your_Contacts_Name

When you run the CheckType tool, the output at the command prompt resembles the following output: !!!!! Message with Subject Subject_Text has a mismatch on property type Actual Proprety 0x81b80102, Expected Property 0x81b8001e
!!!!! Message with Subject Subject_Text has a mismatch on property type Actual Proprety 0x81b80102, Expected Property 0x81b8001e There is a typo of Property as Proprety in the output dataIf you want to save the output data to a file, run the following command:

Checktype "Top Folder%My Folder%My Contacts" > BadContacts.txt

After the CheckType tool has located the corrupted contacts, follow these steps:
  1. Move the corrupted contacts that were found by the CheckType tool to the BadContacts folder in Public Folders.
  2. Run the Search or the Look for query in Outlook to locate contacts in Public Folders. Do this to verify that all corrupted contacts are located.
  3. If the Search or the Look for query does not finish correctly, run the CheckType tool again. Do this to locate more corrupted contacts and to move these contacts to the BadContacts public folder. A duplicate corrupted contact of a contact that you already moved to the BadContacts folder may still exist in the original contacts folder.
  4. Run the Search or the Look for query in Outlook again to locate contacts in Public Folders. Do this to verify that all corrupted contacts have been located.

Modification Type:MajorLast Reviewed:7/26/2006
Keywords:kbtshoot kbprb KB922250 kbAudITPRO