E-mail messages are not being transferred back into Microsoft Dynamics CRM through the Exchange Router (921544)



The information in this article applies to:

  • Microsoft CRM 3.0

SYMPTOMS

E-mail messages are not being transferred back into Microsoft Dynamics CRM through the Exchange Router. Additionally, on the computer that is running Microsoft Exchange Server, the following error message is logged in the Application log:
Microsoft.Crm.Tools.ExchangeConnectorService.ExchangeSinkServiceException: Verifying before delivery message: message_subject in mailbox: mailbox_folder failed (System.Net.WebException: The request failed with HTTP status 401: Unauthorized.

CAUSE

This problem occurs if one or more of the following conditions are true:
  • The user who is running the Microsoft CRM-Exchange E-mail Router Service is not a domain administrator.
  • The Exchange server is not listed in the PrivUserGroup security group in Active Directory directory service.

RESOLUTION

To resolve this problem, use one of the following methods.

Method 1: Change the user who runs the Microsoft CRM-Exchange E-mail Router Service

  1. On the Exchange server, click Start, point to Administrative Tools, and then click Services.
  2. Right-click Microsoft CRM-Exchange E-mail Router Service, and then click Properties.
  3. On the Logon tab, click This Account. Then, enter the name of a user who is a member of the Domain Admin group.
  4. Click OK.
  5. Restart the service.

Method 2: Add the domain administrator user account or the Exchange server computer account to the PrivUserGroup security group in Active Directory

Note If you run the Microsoft CRM-Exchange E-mail Router Service as a domain administrator, you must add this domain administrator user account to the PrivUserGroup security group. If you run the service by using a local system account, you must add the Exchange server computer account to the PrivUserGroup security group.
  1. On the computer on which Active Directory is installed, click Start, point to Administrative Tools, and then click Active Directory Users and Computers.
  2. Expand your organization unit, right-click PrivUserGroup, and then click Properties.
  3. On the Members tab, click Add, and then enter the domain administrator user account or the Exchange server computer account.
  4. Click OK two times.

Modification Type:MajorLast Reviewed:6/26/2006
Keywords:kbtshoot kbMBSMigrate kbprb kberrmsg kbMBSemail KB921544 kbAudKnowledgeWorker kbAudEndUser