Active Directory System Group Discovery may update the time stamp for SMS clients that no longer update their DNS records on a computer that is running SMS 2003 with Service Pack 2 (921463)



The information in this article applies to:

  • Microsoft Systems Management Server 2003 SP2

SYMPTOMS

You are using a computer that is running Microsoft Systems Management Server (SMS) 2003 with Service Pack 2 (SP2). In SMS 2003, you enable and configure the Delete Aged Discovery Data task to remove records that are related to SMS clients that are not active in the Domain Naming System (DNS) from the SMS site database. However, after you configure this task, Active Directory System Group Discovery may still update the time stamp for those SMS clients that no longer update their DNS records.

CAUSE

This problem occurs because of a fault in Active Directory System Group Discovery. Because of this fault, the Delete Aged Discovery Data task incorrectly determines that the SMS client records have been updated recently.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SMS 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Basesvr.dll2.50.4160.21141,769,47228-Feb-200620:35x86
Smsse.dll2.50.2726.999977,82428-Jun-200509:01x86
Smsse.dll2.50.2726.999977,82428-Jun-200509:01x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:9/28/2006
Keywords:kbsmsAdmin kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB921463 kbAudITPRO