Error message when you import a catalog in Commerce Server 2007 on a Windows XP-based computer: "The product catalog was not imported successfully" (920867)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Commerce Server 2007 Developer Edition

SYMPTOMS

When you use Microsoft Commerce Server 2007 Catalog Manager to import a catalog on a Microsoft Windows XP-based computer, you may receive the following error message in the Import Product Catalog dialog box:
Exception: An error occurred on the server during your operation. Try the operation again or contact your administrator if the error persists. The details of the error are captured in the event log on the server.
Task to be completed:
The product catalog was not imported successfully.
Additionally, the following event is logged in the Application log:Event Type: Error
Event Source: Commerce Server Web Services
Event Category: None
Event ID: 1
Date:
Time:
User:
Computer:
Description:
An exception occurred in the 'CatalogWebService' Web service. Exception details follow:

System.ArgumentException: Value does not fall within the expected range.

Server stack trace:
at Microsoft.CommerceServer.Catalog.ICatalogImport.WebServiceImport(String siteName, Guid token, Boolean inventoryImport, String importOptionsXml, Boolean ignoreInventorySystem, String userName, String authorizationPolicyPath)
at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs)
at System.Runtime.Remoting.Messaging.StackBuilderSink.PrivateProcessMessage(RuntimeMethodHandle md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs)
at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg, Int32 methodPtr, Boolean fExecuteInContext)

Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at Microsoft.CommerceServer.Catalog.ICatalogImport.WebServiceImport(String siteName, Guid token, Boolean inventoryImport, String importOptionsXmsl, Boolean ignoreInventorySystem, String userName, String authorizationPolicyPath)
at Microsoft.CommerceServer.Catalog.Internal.CatalogServerContextBase.Import(Guid token, ImportOptions importOptions)

For more information, see Help and Support Center at http://support.microsoft.com.

CAUSE

This problem occurs because of an impersonation problem in Windows XP.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Authz.dll5.1.2600.292562,46408-Jun-200611:07x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the terms that are used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:9/20/2006
Keywords:kberrmsg kbWinXPsp2fix kbWinXPpreSP2fix kbfix kbbug kbQFE kbhotfixserver kbpubtypekc KB920867 kbAudITPRO kbAudDeveloper