You cannot configure a network adapter that resides on a virtual bus to use a static IP address in an automated deployment of Windows Server 2003 (920293)



The information in this article applies to:

  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Datacenter Edition
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition

SYMPTOMS

Consider the following scenario:
  • You use an answer file to perform an automated deployment of Microsoft Windows Server 2003. For example, you use an Unattend.txt file or a Sysprep.inf file for the answer file.
  • The answer file uses the PCIBus, PCIDevice, and PCIFunction headers to identify the network adapter. The answer file uses the TcpipParams header to set any network settings, such as the IP address, the Subnet mask, the default gateway, and so on.
  • The network adapter resides on a virtual bus.
In this scenario, network settings, such as the static IP address, in the answer file are ignored. Instead, the network adapter acquires an IP address from the Dynamic Host Configuration Protocol (DHCP) server after Windows starts.

CAUSE

Assume that you are using an answer file for an automated deployment and that the network card resides on a virtual bus. In this case, you cannot currently set network settings by using an answer file that uses the PCIBus, PCIDevice, and PCIFunction headers to identify the network adapter. Instead, you can use the MAC address of the adapter as the identifier.

RESOLUTION

To resolve this problem, use the Netset03.exe tool from this hotfix to configure the network settings. The tool uses an answer file to perform the configuration of the network components. The procedure follows the same format as an unattended Setup answer file by using the Network section to configure the client. For more information about how to use the Netset03.exe tool, click the following article number to view the article in the Microsoft Knowledge Base:

268781 Description of the Netset.exe tool from the Windows 2000 Resource Kit

Knowledge Base article 268781 discusses the Netset.exe tool from the Windows 2000 Resource Kit. However, the procedure is the same for using the Netset03.exe tool in Windows Server 2003.

Note The Netset03.exe tool will not process the [netoptionalcomponents] section of the unattend file. However, the Sysocmgr.exe tool can be used for the installation of the optional components. The Sysocmgr.exe tool is not needed to configure network components. The Sysocmgr.exe tool is included in Windows Server 2003, and is installed in the %SystemRoot%\System32 folder. Sysocmgr.exe accepts an answer file that has the [components], and [netoptionalcomponents] sections, and then it applies the required entries.

If you use the Sysocmgr.exe tool, you must first run the Netset03.exe tool. This is because certain optional components cannot be installed before the network adapter has been configured. Run the Sysocmgr.exe tool only if you have to use the [netoptionalcomponent] section in your unattend file. For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

136153 Using an answer file for an unattended installation

222444 How to add or remove Windows components with Sysocmgr.exe

323438 How to use Setup Manager to create an answer file in the Windows Server family

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Netset03.exe1.0.0.746,08005-Aug-200619:18x86
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Netset03.exe1.0.0.769,12006-Aug-200612:12x64SP1SP1QFE
Wnetset03.exe1.0.0.746,08006-Aug-200612:12x86SP1WOW
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Netset03.exe1.0.0.7129,02406-Aug-200612:12IA-64SP1SP1QFE
Wnetset03.exe1.0.0.746,08006-Aug-200612:12x86SP1WOW

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates



Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Microsoft Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:9/25/2006
Keywords:kbWinServ2003preSP2fix kbHotfixServer kbQFE kbBug kbExpertiseInter KB920293 kbAudOEM