Error message when you try to add a custom report to Microsoft Dynamics CRM 3.0: "Object reference not set to an instance of an object" (920124)



The information in this article applies to:

  • Microsoft CRM 3.0

SYMPTOMS

When you try to add a custom report to Microsoft Dynamics CRM 3.0, you receive the following error message:
Object reference not set to an instance of an object.

CAUSE

This problem occurs if the data source of the report is a shared data source. The data source of the report must be an embedded data source.

RESOLUTION

To resolve this problem, follow these steps:
  1. Open the report in Report Designer.
  2. On the Data tab, click the lookup button to the right of the Dataset to open Dataset Properties box.
  3. Click the lookup button to the right of the Data Source list.
  4. Click to clear the Use shared data source reference check box.
  5. Click Edit to the right of the Connection box.
  6. In the Server name box, type the server name. Then, select the authentication method and the correct database name.
  7. Click OK two times.
  8. On the File menu, click Save as.
  9. Save the report on the Microsoft Dynamics CRM server, and then add the report.

Modification Type:MajorLast Reviewed:6/15/2006
Keywords:kbMbsreports kberrmsg kbtshoot kbMBSMigrate kbprb KB920124 kbAudEndUser kbAudKnowledgeWorker