WFWG May Hang If TCP/IP Hasn't Registered at Logon Time (92877)
The information in this article applies to:
- Microsoft Windows for Workgroups 3.1
- Microsoft Windows for Workgroups 3.11
This article was previously published under Q92877
The following article contains information on the use of Windows for
Workgroups with third-party products or configurations that have not
been tested and are not supported by Microsoft.
If the steps or procedures described in this article do not function
properly, contact the manufacturer of the third-party product for more
information or use a supported configuration.
SYMPTOMS
If you load TCP/IP as a protocol and then immediately start Windows
for Workgroups from your AUTOEXEC.BAT file, your machine may stop
responding (hang) when you attempt to log on.
CAUSE
This problem occurs because TCP/IP requires time to register on the
network before you log on.
WORKAROUND
To work around the problem, place a pause statement in your AUTOEXEC.BAT
file before the statement that starts Windows, as in the following example:
pause
win
You can also use the MS-DOS 6.0 and 6.2 CHOICE command to force a timed
pause (for example, use "c:\dos\choice /N /T:n,10 Please wait for the
computer to register with the network..."). Refer to your MS-DOS
documentation for more information.
STATUS
This problem occurs with the Microsoft versions of TCP/IP that are
available for Windows for Workgroups 3.11 and Microsoft LAN Manager. This
problem may or may not occur with other implementations of TCP/IP.
Microsoft has confirmed this to be a problem in Windows for Workgroups
version 3.1 and version 3.11. We are researching this problem and will
post new information here in the Microsoft Knowledge Base as it
becomes available.
Modification Type: | Major | Last Reviewed: | 10/14/2003 |
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Keywords: | KB92877 |
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