Software updates from earlier scan tools remain in the Software Updates node in SMS 2003 after you install and configure the Inventory Tool for Microsoft Updates (ITMU) (919779)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

After you install and configure the Inventory Tool for Microsoft Updates (ITMU) in Microsoft Systems Management Server (SMS) 2003, software updates from earlier scanning tools remain in the Software Updates node of the SMS Administrator console. These earlier scanning tools include the following:
  • Microsoft Baseline Security Analyzer (MBSA)
  • Extended Security Update Inventory Tool
  • Microsoft Office Inventory Tool for Updates

CAUSE

This issue occurs because the data from these earlier scanning tools remains in the SMS 2003 database as long as the SMS client computers report the data in hardware inventory. When the SMS client computers stop reporting the existence of the earlier scanning tools, the software update entries are automatically aged out of the SMS database.

RESOLUTION

To resolve this issue, remove the earlier scanning tools. To do this, follow these steps:
  1. Remove the scanning tool by using the Add or Remove Programs item in Control Panel.
  2. Remove the scanning tool from the SMS database. To do this, follow these steps:
    1. Stop the scan advertisements from the earlier scan tools that you want to remove.
    2. Allow sufficient time for the software updates to age out of the SMS database.

    Notes When you run the Scanwrapper program, it examines the Scan.ini file to determine the PatchAge value for a particular software update. The Scanwrapper program uses the PatchAge value to determine the time when a software update becomes inactive. Then, the program removes any update instances that are older than the age specified in the Scan.ini file from Windows Management Instrumentation (WMI). By default, that age is 20 days for all tools that are earlier than ITMU. By default, that age is 30 days for ITMU.

    After the software update has successfully aged out, the expired software updates that remain in the SMS database indicate that one of the following conditions is true:
    • The client computer is either offline or the client computer no longer exists. These kinds of client computers are removed from the SMS database during the database maintenance cycle. By default, this database maintenance cycle runs every 60 days.
    • The client computer is reporting hardware inventory, but the client computer is no longer running the earlier scan tools. In this situation, the hardware inventory data remains in the SMS database until you manually remove the data from the WMI of the client computer or until you configure the client computer to run a scan tool.

MORE INFORMATION

We recommend that you do not manually remove software update data from the UpdateSummary table in the SMS database. You may experience unpredictable results if you do this.

For more information about how to obtain the ITMU, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:6/5/2006
Keywords:kbtshoot kbprb KB919779 kbAudITPRO