Error message that you may receive when you use a version of Windows Server 2003 Authorization Manager that has an XML-based authorization store for Web services: "The process cannot access the file because it is being used by another process" (919754)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition

SYMPTOMS

When you use a version of Windows Server 2003 Authorization Manager (Azman.msc) that has an XML-based authorization store for Web services, you may receive a System.IO.FileLoadException error message that resembles the following:

The process cannot access the file because it is being used by another process.

CAUSE

This problem occurs because of a problem with the Initialize method of Authorization Manager. Typically, this problem occurs if multiple processing threads perform authorization checks at the same time. Authorization checks are performed by multiple threads when several client computers access a Web service.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must not have Authorization Manager running when you install this hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Azroles.dll5.2.3790.2729707,07220-Jun-200613:26IA-64SP1SP1QFE
Wazroles.dll5.2.3790.2729233,47220-Jun-200613:26x86SP1WOW
Windows Server 2003, x64-based version
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Azroles.dll5.2.3790.2729417,79220-Jun-200613:26x64SP1SP1QFE
Wazroles.dll5.2.3790.2729233,47220-Jun-200613:26x86SP1WOW
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Azroles.dll5.2.3790.2729233,47220-Jun-200612:53x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the description of the terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:8/18/2006
Keywords:kbBug kbfix kbQFE kbWinServ2003preSP1fix kbhotfixserver kbpubtypekc KB919754 kbAudITPRO