A picklist field returns no values when you add a picklist field in the associated view of a custom entity in Microsoft Dynamics CRM 3.0 (919645)



The information in this article applies to:

  • Microsoft CRM 3.0

SYMPTOMS

When you add a picklist field in the associated view of a custom entity in Microsoft Dynamics CRM 3.0, the picklist field returns no values.

CAUSE

This problem occurs when you use a reserved word, such as "area" or "relationship," in the schema name of a custom entity. Additionally, this problem occurs only when the schema name follows this pattern:

Prefix_ReservedWordAdditionalCharacters

For example, the problem occurs if the schema name is "new_areas" or "new_areasOfInterest."

RESOLUTION

To resolve this problem, follow one of these guidelines:
  • Do not use a reserved word in the schema name of a custom entity.
  • If you must use a reserved word in the schema name, add an additional underscore or other characters in front of the reserved word. For example, you can use "new__areas" and "new__areasOfInterest" as schema names.

Modification Type:MajorLast Reviewed:7/21/2006
Keywords:kbtshoot kbMBScustomization kbMBSMigrate kbprb KB919645 kbAudEndUser kbAudKnowledgeWorker