Users experience an 11-second delay in folder redirection when a Windows Server 2003 SP1-based computer that is running Terminal Services uses mandatory profiles (919614)



The information in this article applies to:

  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Datacenter Edition
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Standard Edition

SYMPTOMS

After a Microsoft Windows Server 2003 Service Pack 1 (SP1)-based computer that is running Terminal Services is configured to use mandatory user profiles and folder redirection, folder redirection works as expected for the first user who logs on to the remote computer. However, later users experience an 11-second delay in folder redirection for each folder.

CAUSE

This problem occurs because the folder redirection process updates or verifies the client-side caching checksum on the current user's registry when the user logs on to the computer. However, because of the mandatory profile, the checksum changes are not saved in the user's registry. Therefore, the folder redirection code path must time out and regenerate the checksum every time.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To install this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) installed on the computer.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Fdeploy.dll5.2.3790.271379,36031-May-200607:13x86
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Fdeploy.dll5.2.3790.2713211,45630-May-200618:59IA-64SP1SP1QFE
Wfdeploy.dll5.2.3790.271379,36030-May-200618:59x86SP1WOW
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Fdeploy.dll5.2.3790.2713114,17630-May-200618:59x64SP1SP1QFE
Wfdeploy.dll5.2.3790.271379,36030-May-200618:59x86SP1WOW

WORKAROUND

To work around this problem, do not change the user profile to a mandatory profile for the first time that the user logs on to the computer. When the profile is used the first time, the folder redirection updates the client-side caching checksum to the current user's registry only for that time, and the changes are saved permanently. After the user logs off for the first time, you can change the user profile to a mandatory profile. The next time that the profile is used, the registry changes do not occur. Therefore, the delay in folder redirection does not occur when other users log on to the computer.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about how to create a mandatory profile, click the following article number to view the article in the Microsoft Knowledge Base:

168476 How to Create Mandatory Profiles with Windows NT 4.0

For more information about standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

Your hardware manufacturer provides technical support and assistance for x64-based versions of Windows. Your hardware manufacturer provides support because an x64-based version of Windows was included with your hardware. Your hardware manufacturer might have customized the installation of Windows with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your x64-based version of Windows. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbWinServ2003SP1fix kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB919614 kbAudITPRO