The Winlogon.exe process uses excessive CPU resources when a user reinserts a smart card to log on to a Windows Server 2003 Service Pack 1-based terminal server (919578)



The information in this article applies to:

  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Standard x64 Edition
    • Microsoft Windows Server 2003, Enterprise x64 Edition
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems

SYMPTOMS

Consider the following scenario. You have a Microsoft Windows Server 2003 Service Pack 1 (SP1)-based terminal server in your organization. To log on to this terminal server, a user is required to use an Infineon smart card together with the cryptographic service provider (CSP) that is included with Windows Server 2003. When the user exits the terminal server session, the user removes the smart card from the smart card reader that is connected to the client. Although the local system is configured to lock the terminal server session at this point, the local session remains unlocked.

Then, the user reinserts the smart card. Even though the local session is unlocked, the terminal server session no longer responds. Additionally, CPU usage for the Winlogon instance that belongs to the user session increases to almost 100 percent of the system's resources.

CAUSE

This problem occurs because Windows Server 2003 SP1 handles the internal objects for the smart card differently from the way that Windows Server 2003 handles this situation.

The CSP has clean-up code that does not recognize the combination of data field contents. Therefore, the clean-up code generates an endless loop. This behavior causes the session to stop responding (hang). This, in turn, triggers a significant increase in CPU usage.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Windows Server 2003 SP1 installed to apply this hotfix.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003 with SP1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Sccbase.dll5.2.3790.2733193,49626-Jun-200614:27x86
Windows Server 2003 with SP1, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Sccbase.dll5.2.3790.2733334,29625-Jun-200623:44x64SP1Not Applicable
Wsccbase.dll5.2.3790.2733193,49625-Jun-200623:44x86SP1WOW
Windows Server 2003 with SP1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Sccbase.dll5.2.3790.2733652,24825-Jun-200623:45IA-64SP1Not Applicable
Wsccbase.dll5.2.3790.2733193,49625-Jun-200623:45x86SP1WOW

WORKAROUND

To work around this problem, uninstall Service Pack 1 for Windows Server 2003.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:8/16/2006
Keywords:kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB919578 kbAudITPRO