You receive pre-authentication errors when you use keytab files that are generated by using the Ktpass.exe tool on a Windows Server 2003 SP1-based computer (919557)



The information in this article applies to:

  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Web Edition
    • Microsoft Windows Server 2003, Datacenter Edition
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems

SYMPTOMS

Consider the following scenario. You use the Ktpass tool (Ktpass.exe) to create a Kerberos keytab file on a Microsoft Windows Server 2003 Service Pack 1 (SP1)-based computer. When you use Lightweight Directory Access Protocol (LDAP) over a Security Sockets Layer (SSL) connection, the Ktpass tool does not set the account password correctly in Active Directory. When you then use the keytab files that were created by using the Ktpass tool, pre-authentication errors occur.

CAUSE

This problem occurs because of an issue with the Ktpass tool that is included with Windows Server 2003 SP1. The Ktpass tool does not reset the password correctly by using LDAP over SSL.

The Ktpass tool salts the password incorrectly when it generates keytabs for computer accounts. The Ktpass tool uses the host name part of the servicePrincipalName attribute instead of the samAccountName attribute that the Key Distribution Center (KDC) uses to salt the password. The incorrectly generated keytab files that are created by using incorrect salts cause the authentication failure.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Your computer must be running Windows Server 2003 SP1 to install this hotfix.

Restart Requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003, Itanium-based version
File nameFile versionFile sizeDateTimePlatform
Ktpass.exe5.2.3790.2732320,00023-Jun-200620:14IA-64
Windows Server 2003, x64-based version
File nameFile versionFile sizeDateTimePlatform
Ktpass.exe5.2.3790.2732145,92023-Jun-200620:13x64
Windows Server 2003, x86-based version
File nameFile versionFile sizeDateTimePlatform
Ktpass.exe5.2.3790.273291,13623-Jun-200620:13x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the description of the terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:8/17/2006
Keywords:kbWinServ2003preSP2fix kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB919557 kbAudITPRO