Windows Event Collector stops responding when it tries to process System event log data on a computer that is running Windows Server 2003 R2 (919256)



The information in this article applies to:

  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition

SYMPTOMS

When Microsoft Windows Event Collector tries to process System event log data, Event Collector stops responding and data is not written to the expected log files. This behavior occurs on a computer that is running an English version of Microsoft Windows Server 2003 R2.

CAUSE

This problem occurs when Russian is selected as the Language for non-Unicode programs regional setting.

WORKAROUND

To work around this problem, change the Language for non-Unicode programs regional setting from Russian to English (United States). To change this setting, follow these steps:
  1. Click Start, click Run, type intl.cpl, and then click OK.
  2. In the Regional and Language Options dialog box, click the Advanced tab.
  3. In the Language for non-Unicode programs area, select English (United States), and then click OK.

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must be running Windows Server 2003 R2 to install this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003 R2, 64-bit x64-based versions
File nameFile versionFile sizeDateTimePlatform
Wsmselpl.dll5.2.3790.2703181,24816-May-200603:30x64
Windows Server 2003, 64-bit Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Wsmselpl.dll5.2.3790.2703270,33616-May-200603:29IA-64
Windows Server 2003, 32-bit x86-based versions
File nameFile versionFile sizeDateTimePlatform
Wsmselpl.dll5.2.3790.2703104,96016-May-200603:10x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:6/29/2006
Keywords:kbServer kbQFE kbfix KB919256 kbAudITPRO