A rapid increase in database size causes server performance to deteriorate in Exchange Server 2003 and in Exchange 2000 Server (919207)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange 2000 Enterprise Server
  • Microsoft Exchange 2000 Server

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

You may notice a rapid increase in database size on a server that is running Microsoft Exchange Server 2003 or Microsoft Exchange 2000 Server. You may also experience an increase in the number of transaction log files. These increases cause server performance to deteriorate.

CAUSE

This problem occurs if the following conditions are true:
  • You use Microsoft Outlook to connect to the Exchange server.
  • You are running third-party search engines that are integrated with the Outlook desktop.
These search engines may create many search folders in the Exchange database. These search folders cause the symptoms that are mentioned in the "Symptoms" section.

RESOLUTION

To resolve this problem, use either of the following methods.

Method 1: Use Microsoft Office Outlook 2003 in cached mode

When you use Outlook 2003 in cached mode, most search engines do not affect the database. Additionally, when you use cached mode, search engines typically do not index mailbox content on the server. These search engines work against a local copy of the mailbox. Therefore, these search engines do not affect server performance.

Note Server performance will still be affected when you use these search engines to search public folders.

Method 2: Restrict client computer connections to the server

To resolve this problem, restrict client connections that may be causing this problem. To identify clients that may be causing the problem, monitor the baseline performance of the Exchange server for unusual client activity. Several tools are available to monitor the Exchange server.

The following sections describe how to monitor the Exchange server and how to restrict client connections to the server.

How to monitor the Exchange server for unusual client activity

You must continually monitor the Exchange server for free disk space on log drives and on database drives. You can also monitor the following performance counter:

MSExchangeIS\RPC Operations/Sec

You can identify unusual client activity on the server by monitoring the free disk space and this performance counter.

If you discover unusual client activity, you can use the Exchange Server User Monitor tool (ExMon.exe) to identify specific MAPI clients that are responsible for the highest activity on the server. To obtain the Exchange Server User Monitor tool, visit the following Microsoft Web site: For information about how to use the Exchange Server User Monitor tool, see the tool usage documentation. This documentation is available in the installation folder after you install the tool.

Additionally, you can use the Microsoft Exchange Troubleshooting Assistant tool to collect and to analyze performance information. To download the Microsoft Exchange Troubleshooting Assistant tool, visit the following Microsoft Web site:

How to restrict client connections to the Exchange server

You can use one of the following methods to restrict client connections to the server.Method A: Restrict connections that are based on the client MAPI versionWarning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

You can restrict connections from clients that have a specific MAPI version. To do this, follow these steps:
  1. Create a new registry entry under the following registry subkey:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  2. Configure the following values for this registry entry:

    Value name: Disable MAPI Clients
    Value type: REG_SZ
    Value data: v1, v2 - v3, - v4, v5 -

  3. Restart the Microsoft Exchange Information Store service from the Services snap-in. Do this even if the server is in a cluster environment.

    Note This step is applicable only for Exchange 2000 Server. In Exchange Server 2003, changes to the ParametersSystem registry subkey are dynamically detected. The following behavior occurs in Exchange Server 2003:
    • Every 15 minutes, the store queries the ParametersSystem registry key.
    • Any changes to this registry key are immediately put into effect.
    • If any open connections were established by using the MAPI version that you blocked, these connections are immediately disconnected.
    • All new connections are blocked if you are using a version of a MAPI client that has been blocked.
You can indicate all the specific versions or the ranges of versions that you want to disable in the Value data string. You can use Exchange System Manager to determine the version number of each MAPI client that is connected to the mailbox store. To do this, start Exchange System Manager, and then locate the Logons container of the mailbox store. The version number of each MAPI client that is connected to the mailbox store appears in the Client Version column.

Important The MAPI client version number is listed in Exchange System Manager as X.0.Y.Z. In the registry value, you must enter the version number as X.Y.Z. For example, if the MAPI client version is listed as 5.0.2819.0 in Exchange System Manager, type 5.2819.0 in the Value data box for the Disable MAPI Clients registry entry. Additionally, server-side Exchange components also use MAPI to log on. Some components report their client version as an Exchange build number. Therefore, avoid restricting client version 6.x.x from connecting to Exchange servers.

For more information about this method, click the following article number to view the article in the Microsoft Knowledge Base:

288894 How to disable MAPI client access to an Exchange Server 2003 computer or to an Exchange 2000 Server computer

Method B: Restrict the load that is caused by clientsTo restrict the server load that is caused by clients, you can limit the number of messages that can be held open by each client. To do this, follow these steps:
  1. Create a new registry entry under the following registry subkey:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  2. Configure the following values for this registry entry:

    Value name: MaxOpenMessagesPerLogon
    Value type: REG_DWORD
    Value data: 500 (decimal)

    Note Set the Value data parameter to the number of messages that can be held open by each client logon. A value of 500 is recommended for most environments.
  3. Restart the Microsoft Exchange Information Store service from the Services snap-in.
For more information about this method, click the following article number to view the article in the Microsoft Knowledge Base:

289109 How to limit the number of messages opened for each MAPI logon

Method C: Prevent specific executable files from connecting to Exchange Server 2003You can restrict client connections to the Exchange Server 2003 server based on the executable file name of the MAPI program. To do this, install the hotfix that is described in the following Microsoft Knowledge Base article. For more information about how to do this, click the following article number to view the article in the Microsoft Knowledge Base:

920185 A feature is available to disable MAPI program access to a computer that is running Exchange Server 2003

MORE INFORMATION

Control client-based software that connects to the Exchange server

When you enable full MAPI functionality for clients, you must control the software that is installed on clients to prevent unapproved programs from connecting to Exchange. When unapproved programs connect to Exchange, the load from generic client connections may be significantly more than you planned for organizational users and for MAPI users.

In Exchange Server 2003 Service Pack 2 (SP2), administrators can restrict MAPI access for each user. When you do this, you will have more control to correct a certain user's configuration. Therefore, you can avoid using methods that may affect all users who connect to a particular store.

For more information about administration features that are available in Exchange Server 2003, view the following Microsoft Web site:

REFERENCES

For more information about issues that may occur with desktop search engines that are integrated with MAPI clients, click the following article number to view the article in the Microsoft Knowledge Base:

905184 Exchange 2000 Server and Exchange Server 2003 performance may be affected when desktop search engine software is running on Outlook or other MAPI client computers


Modification Type:MinorLast Reviewed:8/22/2006
Keywords:kbtshoot kbprb KB919207 kbAudITPRO