FIX: Event ID 8198 and event ID 8210 may be logged in the Application log when you run the NIS on a computer that is running Microsoft Windows Services for UNIX 3.5 (919171)



The information in this article applies to:

  • Microsoft Windows Services for UNIX 3.5

SYMPTOMS

When you run the Network Information Service (NIS) on a computer that is running Microsoft Windows Services for UNIX 3.5, the following events may be logged in the Application log:
  • Event ID 8198, Source nissvc: "Server for NIS yppush service has stopped"
  • Event ID 8210, Source nissvc: "Unable to create the RPC service."
Additionally, you may notice that updates to NIS-enabled objects in the Active Directory directory service are not reflected in the NIS maps. For example, after you change a user password, the new password may not be reflected in the NIS maps.

CAUSE

This problem may occur because the Server for NIS service does not receive a response from Active Directory within the expected time.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To install the hotfix, you must be running Windows Services for UNIX 3.5.

Restart requirement

You must restart the Server for NIS service after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Nissvc.exe8.0.1969.44187,39214-Jul-200613:20x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

By default, the LDAP query time-out period in the Server for NIS service is 60 seconds. This hotfix increases the default LDAP query time-out period to 130 seconds. Additionally, this hotfix creates the following new registry subkey value of type DWORD that can be used to customize the time-out period:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Server for NIS\Ldap_Timeout

Notes
  • The Ldap_Timeout registry subkey value is measured in seconds.
  • Communication with Active Directory may take longer than expected in domains that have hundreds of thousands of objects or when the domain controller is heavily loaded.

REFERENCES

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

867876 FIX: Subordinate NIS servers do not receive the most up-to-date maps

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:8/22/2006
Keywords:kbQFE kbpubtypekc KB919171 kbAudDeveloper kbAudITPRO