SYMPTOMS
When you use a Collaboration Data Objects for Exchange (CDOEX)-based program to save an appointment item to another user's calendar in a Microsoft Exchange Server 2003 organization, you receive an error message on the Results page. The error message resembles the following:
Result
Description:Transaction failed to commit for an unknown reason.
Source:CDO.Appointment.1
Number:-2147168254
This problem occurs after you apply hotfix 895949.
CAUSE
This problem occurs because hotfix 895949 introduces a change in the implementation of the "Send As" user right. This change was introduced to give administrators more direct control when they assign the "Send As" user right.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
895949
"Send As" permission behavior change in Exchange 2003
RESOLUTION
Hotfix information
A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.
To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
Hotfix installation information
After you apply hotfix 919169, the calendar information that is to be posted to another user's calendar is treated as an IPM.Schedule message class. This grants the user the "Send on behalf of" user right.
Prerequisites
You must install Microsoft Exchange Server 2003 Service Pack 2 (SP2) before you apply the hotfix.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993
How to obtain the latest service packs for Exchange Server 2003
Restart requirement
You do not have to restart the computer after you apply the hotfix. However, the Microsoft Exchange Information Store service and all dependent services will be restarted.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The Global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the
Time Zone tab in the Date and Time item in Control Panel.
|
Exosal.dll | 6.5.7651.45 | 70,144 | 24-Aug-2006 | 22:21 | x86 |
Mdbmsg.dll | 6.5.7651.45 | 3,372,544 | 24-Aug-2006 | 16:54 | x86 |
Store.exe | 6.5.7651.45 | 5,258,752 | 24-Aug-2006 | 22:22 | x86 |