The address book function on Exchange 12 is broken when the Exchange OWA client and the Windows Server 2003-based domain controller do not have the same locale setting (919166)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems

Beta Information

This article discusses a Beta release of a Microsoft product. The information in this article is provided as-is and is subject to change without notice.

No formal product support is available from Microsoft for this Beta product. For information about how to obtain support for a Beta release, see the documentation that is included with the Beta product files, or check the Web location where you downloaded the release.

SYMPTOMS

When you try to access the Address Book in Microsoft Outlook Web Access you may receive an exception that resembles the following: Request Url: https://192.168.0.1:443/owa/forms/premium/DirectoryView.aspx?ae=AddressList&t=Recipients&a=Pick
User host address: 192.168.0.2
User: someone
EX Address: /o=HUJIX/ou=GR/cn=RECIPIENTS/cn=SOMEONE
SMTP Address: someone@adatum.com
OWA version: 8.0.605.16
Mailbox server: mail.adatum.com

CAUSE

On a Microsoft Windows Server 2003-based domain controller that has Microsoft Exchange Server 2007, code-named Exchange "12" installed, the address book (AB) function on Exchange 12 does not work when the Exchange Outlook Web Access (OWA) client and the domain controller do not have the same locale setting.

OWA lets users select the language that they want to use for their user interface (UI). The language that users select determines the locale setting. OWA also uses that language to sort Active Directory results, such as the address book. When Exchange runs a Virtual List Views (VLV) query and specifies a language that is not available on the domain controller, an error occurs. This problem occurs because there is currently no default indexing mechanism that enables Exchange to use a different language if the language that is specified for a VLV query does not match the language of the domain controller.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To receive this hotfix, you must have Microsoft Exchange 2007 in your environment.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions with Service Pack 1
File nameFile versionFile sizeDateTimePlatformSP requirement
Ntdsa.dll5.2.3790.27001,521,15211-May-200603:58x86SP1
W03a2409.dll5.2.3790.270025,60011-May-200601:30x86SP1
Windows Server 2003, x64-based versions with Service Pack 1
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdsa.dll5.2.3790.27002,966,01610-May-200613:25x64SP1Not Applicable
W03a2409.dll5.2.3790.270026,11210-May-200613:25x64SP1Not Applicable
Wntdsa.dll5.2.3790.27001,521,15210-May-200613:25x86SP1WOW
Ww03a2409.dll5.2.3790.270025,60010-May-200613:25x86SP1WOW
Windows Server 2003, Itanium-based versions with Service Pack 1
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdsa.dll5.2.3790.27004,251,64810-May-200613:26IA-64SP1Not Applicable
W03a2409.dll5.2.3790.270024,57610-May-200613:26IA-64SP1Not Applicable
Wntdsa.dll5.2.3790.27001,521,15210-May-200613:26x86SP1WOW
Ww03a2409.dll5.2.3790.270025,60010-May-200613:26x86SP1WOW

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the terms that are used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:9/22/2006
Keywords:kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB919166 kbAudITPRO