FIX: Error message when you run SQL Server 2005 Mobile Edition: "80004005 unspecified error" (919150)



The information in this article applies to:

  • Microsoft SQL Server 2005 Mobile Edition

SYMPTOMS

When you run Microsoft SQL Server 2005 Mobile Edition (SQL Server Mobile) on a Microsoft Windows Powered Pocket PC 2003-based device, you receive the following error message:
80004005 UNSPECIFIED error
This problem occurs when the following conditions are true:
  • The SQL Server Mobile engine tries to access the .sdf database file on the storage card.
  • The device was just restored from the suspend mode.

CAUSE

This problem occurs because the block device driver has not yet started when the device is just restored from the suspend mode. Therefore, when the SQL Server Mobile engine tries to access the .sdf database file on the storage card, the storage system returns the following error message:
device is busy

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SQL Server Mobile service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

This hotfix is for Windows Powered Pocket PC 2003-based devices that use the ARMV4I microprocessor.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Sqlcecompact30.dll3.0.5207.171,16809-May-200623:56:02ARMV4
Sqlcese30.dll3.0.5207.2400,89610-May-200602:23:26ARMV4
Note Because of file dependencies, the most recent hotfix or feature that contains these files may also contain additional files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

To apply this hotfix, extract the Sqlce30.PPC.wce4.armv4.cab file and the Sqlce30.repl.PPC.wce4.armv4.cab file from the hotfix. Then, install these files on the device.

This hotfix updates the error message that you receive in SQL Server Mobile when this problem occurs. The updated error message is more descriptive than the error message that is mentioned in the "Symptoms" section. The updated error message is one of the following:

Error message 1

The disk is not ready

Error message 2

The OS storage system (RAM, CF, SD, or IPSM) is not responding. Retry the operation

Modification Type:MajorLast Reviewed:6/29/2006
Keywords:kbfix kbQFE kbHotfixServer kbExpertiseAdvanced KB919150 kbAudDeveloper kbAudITPRO