You experience problems when you try to open an attachment after you move a database in Exchange 2000 Server (919078)



The information in this article applies to:

  • Microsoft Exchange 2000 Enterprise Server
  • Microsoft Exchange 2000 Server

SYMPTOMS

After you move an Exchange Information Store database from one computer to another computer that is running Microsoft Exchange 2000 Server, you experience problems when you try to open an attachment in an e-mail message. You experience different symptoms depending on the program or the method that you use to open the attachment. For example, you may experience the following symptoms:
  • You cannot access an attachment even though the attachment icon is displayed in the message.
  • If you are using Microsoft Outlook in Corporate mode, or MAPI mode, you receive the following error message when you try to open an attachment:
    Operation failed
  • If you are using Microsoft Outlook Web Access or Outlook as a POP3 client, you can open an attachment. But, the attachment is blank. Additionally, the following event may be logged in the Application log:Event ID: 12003
    Category: Content Engine
    Description: Error 80070003-82000387 occurred while processing message. Message information

CAUSE

This problem occurs if the working directory is missing.

RESOLUTION

To resolve this problem, manually create the missing working directory on the computer that is running Exchange 2000 Server. To do this, follow these steps:
  1. Verify the location of the working directory. To do this, view the following registry entry:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\WorkingDirectory

    Typically, the working directory is at the following location:

    Drive_Letter:\Exchsrvr\Mdbdata

  2. Move to the Drive_Letter:\Exchsrvr folder, and then create an Mdbdata folder.
  3. Restart the Microsoft Exchange Information Store service.

Modification Type:MinorLast Reviewed:6/6/2006
Keywords:kbtshoot kbprb KB919078 kbAudITPRO