You receive a JOB_STATUS_PRINTED print job notification even though the printer is turned off when you try to print a document from a Windows Server 2003-based computer (919017)



The information in this article applies to:

  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition

SYMPTOMS

When you try to print a document from an application on a Microsoft Windows Server 2003-based computer, you receive a JOB_STATUS_PRINTED print job notification, even though the document is not printed. You experience this symptom when the following conditions are true:
  • The shared printer is turned off.
  • The server uses a standard TCP/IP port for communication.
  • The server uses the Line Printer Remote (LPR) protocol for sending print jobs to a shared printer.
  • The LPR Byte Counting Enabled option is enabled on the server.

CAUSE

This problem occurs because the print spooler does not manage print jobs correctly. If the print spooler receives a RESTART_JOB_CONTROL notification before the EndDoc function call, the print spooler does not set the job status to JOB_PRINTED. However, if the print spooler receives the RESTART_JOB_CONTROL notification during the EndDoc function call, the print spooler marks the job status as printed and indicates to the printer that the print job status has changed. The print job is not processed. The print job status is marked as JOB_RESTART and JOB_PRINTING.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Localspl.dll5.2.3790.530312,32009-May-200603:01x86NoneRTMQFE
Spoolss.dll5.2.3790.53081,92009-May-200603:01x86NoneRTMQFE
Localspl.dll5.2.3790.2698348,67209-May-200603:47x86SP1SP1QFE
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Localspl.dll5.2.3790.530860,67208-May-200615:56IA-64NoneRTMQFE
Spoolss.dll5.2.3790.530235,00808-May-200615:56IA-64NoneRTMQFE
Localspl.dll5.2.3790.2698968,70408-May-200616:04IA-64SP1SP1QFE
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.2698750,08008-May-200616:02x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

Your hardware manufacturer provides technical support and assistance for x64-based versions of Windows. Your hardware manufacturer provides support because an x64-based version of Windows was included with your hardware. Your hardware manufacturer might have customized the installation of Windows with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your x64-based version of Windows. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:8/10/2006
Keywords:kbWinServ2003preSP2fix kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB919017 kbAudITPRO