Error message when you open the Internet Explorer 6 Favorites pane in Windows XP or in Windows Server 2003: "Iexplore.exe has generated errors" (918956)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0, when used with:
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition

SYMPTOMS

On a computer that is running Microsoft Windows Server 2003 or Microsoft Windows XP, you receive the following error message when you open the Favorites pane in Microsoft Internet Explorer 6:
Iexplore.exe has generated errors and will be closed by Windows. You will need to restart the program.

An error log is being created.
Then, Internet Explorer 6 unexpectedly exits.

CAUSE

This problem occurs when a Microsoft Internet Explorer Maintenance policy setting is applied to the computer, and the Favorites pane is open.

RESOLUTION

Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have the original release version of Windows Server 2003 or Windows Server 2003 with Service Pack 1 (SP1) installed.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003 with SP1
File nameFile versionFile sizeDateTimePlatform
Shdocvw.dll6.0.3790.27011,513,98412-May-200603:35x86
Windows Server 2003
File nameFile versionFile sizeDateTimePlatform
Browseui.dll6.0.3790.4971,057,28004-Mar-200603:28x86
Shdocvw.dll6.0.3790.532 1,398,78412-May-200603:07x86

Windows XP

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 (SP2) or Windows XP Service Pack 1 (SP1) installed.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows XP with SP2
File nameFile versionFile sizeDateTimePlatform
Shdocvw.dll6.0.2900.29051,496,57610-May-200613:09x86
Windows XP with SP1
File nameFile versionFile sizeDateTimePlatform
Shdocvw.dll6.0.2800.18391,339,90410-May-200622:41x86

WORKAROUND

To work around this problem, do not open the Favorites pane in Internet Explorer 6 when an Internet Explorer Maintenance policy is applied to the computer.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the terms that are used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbWinServ2003preSP2fix kbWinXPpreSP3fix kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB918956 kbAudITPRO kbAudEndUser