When you try to log on interactively to a Windows XP-based client computer, the user object logon script does not run (918495)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

When you try to log on interactively to a Microsoft Windows XP-based client computer, the user object logon script does not run. This problem occurs even though the Allow Cross-Forest User Policy and Roaming User Profiles policy setting is enabled.

This problem occurs when you log on by using a user account from a domain that differs from the domain of the computer account.

CAUSE

This problem occurs because the Userinit.exe file cannot execute the logon script because of name resolution problems. This behavior occurs if the following conditions are true:
  • NetBIOS over TCP/IP (NetBT) name resolution is not available to resolve the flat name of the logon server. NetBT includes Windows Internet Naming Service (WINS) broadcasts.
  • The Domain Name System (DNS) domain name of the user account is not added to the DNS suffix search list of the client computer.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Microsoft Windows XP Service Pack 2

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

Hotfix installation information

When you install the hotfix, an updated version of the Userinit.exe file and of the System.adm file are installed together with the hotfix package. The System.adm file contains the following new Group Policy object (GPO) setting:

Computer Configuration\Administrative Templates\System\Group Policy\Allow LogonScripts with NetBIOS disabled

This setting lets you enable or disable logon scripts when NetBIOS is disabled.

Registry information

If you enable the new feature by using the new GPO, the following registry subkey is configured:

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System\Allow-LogonScript-NetBIOSDisabled
Value Type: DWORD
Value Data: 00000001

You must also enable the Allow Cross-Forest User Policy and Roaming User Profiles GPO. When you do this, the following registry subkey is configured:

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System\AllowX-ForestPolicy-and-RUP
Value Type: DWORD
Value Data: 00000001

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimeSP requirement
System.admNot Applicable1,745,72030-Jun-200608:54SP2
Userinit.exe5.1.2600.294326,11203-Jul-200608:53SP2

WORKAROUND

To work around this problem, use one of the following methods.

Method 1: Enable NetBT name resolution

  1. Click Start, click Run, type ncpa.cpl, and then click OK.
  2. In Network Connections, right-click Local Area Connection, and then click Properties.
  3. Click Internet Protocol (TCP/IP), and then click Properties.
  4. In the Internet Protocol (TCP/IP) Properties dialog box, click Advanced.
  5. On the WINS tab, click Enable NetBIOS Over TCP/IP, and then click OK three times.
Note This method works only if the following conditions are true:
  • The WINS topology contains the domain controller records from the account domain.
  • The domain controllers can be accessed by using NetBT broadcasts.

Method 2: Add the DNS domain name of the user account to the DNS suffix search list of the client

  1. Click Start, click Run, type ncpa.cpl, and then click OK.
  2. In Network Connections, right-click Local Area Connection, and then click Properties.
  3. Click Internet Protocol (TCP/IP), and then click Properties.
  4. In the Internet Protocol (TCP/IP) Properties dialog box, click Advanced.
  5. On the DNS tab, click Append these DNS suffixes [in order], and then click Add.
  6. In the Domain Suffix field, type the domain name that you want to add, and then click Add.
  7. Click OK three times.
Note You can also use a GPO to configure DNS suffixes.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

To publish the new registry setting in Group Policy for a domain, you must modify the new GPO that is contained in the System.adm file. Modify the System.adm file on a computer that is running Window XP Service Pack 2 and that has hotfix 918495 installed. The Group Policy Object Editor copies the new version of the System.adm file to the related Administrative Template (ADM) directory on the system volume (SYSVOL) and makes the new setting available.

For more information about ADM files, click the following article number to view the article in the Microsoft Knowledge Base:

816662 Recommendations for managing Group Policy administrative template (.adm) files

REFERENCES

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:8/23/2006
Keywords:kbWinXPsp2fix kbWinXPpreSP2fix kbfix kbbug kbQFE kbprb kbhotfixserver kbpubtypekc KB918495 kbAudDeveloper