FIX: You receive a ThreadAbortException exception in an ASP.NET Web application that is based in the .NET Framework 2.0 when the Async page directive property is set to true (918181)



The information in this article applies to:

  • Microsoft .NET Framework 2.0

SYMPTOMS

You receive a ThreadAbortException exception in a Microsoft ASP.NET Web application that is based on the Microsoft .NET Framework 2.0 when the following conditions are true:
  • You set the Async page directive property to true. For example, you use the following line of code.
    <%@ Page Language="C#" Async="true"%>
  • You call the HttpResponse.Redirect method.
You receive an exception message that resembles the following:
[ThreadAbortException: Thread was being aborted.]
System.Web.HttpContext.InvokeCancellableCallback(WaitCallback callback, Object state) +311
System.Web.UI.PageAsyncInfo.CallHandlers(Boolean onPageThread) +68

[HttpException (0x80004005): Exception of type 'System.Web.HttpException' was thrown.]
System.Web.HttpAsyncResult.End() +3278107
System.Web.UI.Page.AsyncPageEndProcessRequest(IAsyncResult result) +21
ASP.page_001_aspx.EndProcessRequest(IAsyncResult ar) +4
System.Web.CallHandlerExecutionStep.OnAsyncHandlerCompletion(IAsyncResult ar) +57
--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework
Version:2.0.50727.42; ASP.NET Version:2.0.50727.42

CAUSE

This problem occurs when the endResponse parameter of the HttpResponse.Redirect method is not set to false. By default, the endResponse parameter is set to true.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next .NET Framework 2.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTime
Aspnet_wp.exe2.0.50727.10323,04019-Apr-200607:55
System.web.dll 2.0.50727.1035,025,79219-Apr-200607:56
Webengine.dll 2.0.50727.103299,52019-Apr-200607:55

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information, visit the following Microsoft Developer Network (MSDN) Web sites:

Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB918181 kbAudDeveloper kbAudITPRO