Error message when you try to upgrade to Microsoft Dynamics CRM 3.0: "Microsoft CRM 3.0 server setup did not complete successfully" (918110)



The information in this article applies to:

  • Microsoft CRM 3.0

SYMPTOMS

When you try to upgrade from Microsoft CRM 1.2 to Microsoft Dynamics CRM 3.0, you may receive the following error message:
Microsoft CRM 3.0 server setup did not complete successfully.
Additionally, you may find the following error message in the setup log:
Action Microsoft.Crm.Setup.Server.InstallDatabaseAction failed.
The Snapshot Agent corresponding to the publication 'OrganizationName_METABASE' could not be dropped. Could not drop the publication.
The Snapshot Agent corresponding to the publication 'OrganizationName_MSCRM' could not be dropped. Could not drop the publication.
Note In the setup log error message, OrganizationName represents the actual organization name.

CAUSE

This problem occurs because the Microsoft CRM 3.0 setup process cannot drop the replication that is used for the MSCRM and METABASE databases.

RESOLUTION

To resolve this problem, follow these steps:
  1. Uninstall Microsoft CRM 3.0, and then restore the Microsoft CRM 1.2 database. To do this, follow these steps:
    1. See the following article in the Microsoft Knowledge Base:

      915094 How to roll back an upgrade from Microsoft Business Solutions CRM 1.2 to Microsoft Dynamics CRM 3.0

    2. Complete the following sections of the article:
      • "How to uninstall the Microsoft CRM 3.0 binary components"
      • "How to roll back the Microsoft CRM databases to Microsoft CRM 1.2"
    Note You do not have to reinstall Microsoft CRM 1.2.
  2. Enable publishing. To do this, use one of the following methods.

    Method 1

    If Microsoft CRM Deployment Manager is still installed, follow these steps:
    1. Log on to the Microsoft CRM server as a Microsoft CRM System Administrator user.
    2. Click Start, point to Programs, point to Microsoft CRM, and then click Deployment Manager.
    3. In Deployment Manager, click Server Manager, right-click the name of the Microsoft CRM server, and then click Configure SQL Server.
    4. Click the instance of Microsoft SQL Server in the SQL Server list, click Next, and then click Finish.
    Note If you cannot enable publishing by using Deployment Manager, follow the steps in method 2.

    Method 2

    If Microsoft CRM Deployment Manager is unavailable, follow these steps:
    1. Log on to the instance of Microsoft SQL Server as a SQL Server administrator user.
    2. Click Start, point to Programs, point to Microsoft SQL Server, and then click Query Analyzer.
    3. In the Connect to SQL Server dialog box, click the instance of Microsoft SQL Server in the SQL Server list, and then click OK.
    4. Click the OrganizationName_MSCRM database in the list of databases.

      Note OrganizationName represents the actual organization name.
    5. Run the following script in SQL Query Analyzer.
      EXEC p_CRMReplicationSetup 
      '<SQL Server name>', '<SQL Server name>', '<Microsoft CRM MSCRM database name>', 
      '<Microsoft CRM METABASE database name>', '<Replication SQL Server directory>', 
      '<SQL logon group name>', '<Microsoft CRM MSCRMDistribution database name>' 
      Notes
      • In the script, <SQL Server name> represents the actual SQL Server name.
      • In the script, <Microsoft CRM MSCRM database name> represents the actual MSCRM database name. This name has the following format:

        OrganizationName _MSCRM

      • In the script, <Microsoft CRM METABASE database name> represents the actual METABASE database name. This name has the following format:

        OrganizationName _METABASE

      • OrganizationName represents the actual organization name.
      • In the script, <Replication SQL Server directory> represents the path of the Repldata directory on the SQL server. By default, this path is the following path:

        C:\Program Files\Microsoft SQL Server\Mssql\Repldata

      • In the script, <SQL logon group name> represents the actual SQL logon group name. This name has the following format:

        DomainName\SQLRepl {GUID}

        Note DomainName represents the actual domain name. GUID represents an actual GUID. For example, the GUID could be the following string:

        E5334FB9-440A-4BD8-A19A-0FA54E6B248C



        To find the SQL logon group name, follow these steps:
        1. On the computer that is running Microsoft SQL Server, click Start, point to Programs, point to Microsoft SQL Server, and then click Enterprise Manager.
        2. In Enterprise Manager, expand Microsoft SQL Servers, expand SQL Server Group, expand the instance of the server where Microsoft CRM was installed, expand Security, and then click Logins.
        3. Right-click DomainName\SQLRepl {GUID}, and then click Properties.
        4. In the Properties dialog box, click the Database Access tab.
        5. The SQL logon group names are the names in the User column. You can use one of these names.
      • In the script, <Microsoft CRM MSCRMDistribution database name> represents the distribution database name. This name that has the following format:

        OrganizationName_MSCRMDistribution

        Notes
        • If you do not see this database in SQL server, specify the database name as OrganizationName_MSCRMDistribution.
        • OrganizationName represents the actual organization name.
  3. Verify that the replication components were created. To do this, follow these steps:
    1. Log on to the SQL server as a SQL Server administrator user.
    2. Click Start, point to Programs, point to Microsoft SQL Server, and then click Enterprise Manager.
    3. In Enterprise Manager, expand Microsoft SQL Servers, expand SQL Server Group, expand the instance where Microsoft CRM was installed, and then expand Replication Monitor.
    4. Expand Publishers, and then expand the SQL server.

      Note You can find two publishers. One has the prefix CRMMetaPub, and the other has the prefix CRMPub.
    5. Click CRMMetaPub, right-click Snapshot, and then click Start Agent.
    6. Click CRMPub, right-click Snapshot, and then click Start Agent.

      Notes
      • The snapshot publications may take from five to ten minutes to finish.
      • After the CRMMetaPub snapshot is completed, you receive the following message:
        A snapshot of 79 article(s) was generated.
      • After the CRMPub snapshot is completed, you receive the following message:
        A snapshot of 93 article(s) was generated.
    7. Verify that the schedule for the snapshot jobs was deleted. To do this, follow these steps:
      1. Right-click the CRMMetaPub snapshot, and then click Agent Properties.
      2. In the Agent dialog box, click the Schedule tab.
      3. Highlight all listed jobs, click Delete, and then click OK.
      4. Repeat steps g1 through g3 for the CRMPub snapshot agent.
  4. In Enterprise Manager, right-click Replication, click Disable Publishing and Distribution, and then follow the instructions that appear on the screen to disable the replication.
  5. Delete the ASReplicationObjects table from the MSCRM and METABASE databases.
  6. Repeat step 3.
  7. Upgrade Microsoft CRM 3.0 again.

Modification Type:MinorLast Reviewed:8/8/2006
Keywords:kbtshoot kbMBSupgrade kberrmsg kbMBSMigrate kbprb KB918110 kbAudEndUser kbAudKnowledgeWorker