Error message when you try to go offline on a laptop client computer that is running Microsoft Dynamics CRM 3.0: "Failed move data for entity" (918108)



The information in this article applies to:

  • Microsoft CRM client for Microsoft Office Outlook, when used with:
    • Microsoft CRM 3.0

The hotfix that is discussed in this article is not available for the Chinese version of Microsoft Dynamics CRM or for the Japanese version of Microsoft Dynamics CRM.

SYMPTOMS

When you try to go offline on a laptop client computer that is running Microsoft Dynamics CRM 3.0, you cannot go offline successfully. You receive the following error message:
Failed move data for entity 'entity_name' during action salnsert, countRows=1. Contact your system administrator for assistance and try going offline again.
Additionally, the following error message is logged in the Application log on the laptop client computer: Event Type: Error
Event Source: MSCRMOfflineSync
Event Category: None
Event ID: 6000
Date: date
Time: time
User: user_name
Computer: computer_name

Description:

An error occurred during Offline Synchronization. Try going offline again, or restart Microsoft Outlook. saInsert failed for entity 'Account', batchRows=0 with exception System.Data.SqlClient.SqlException: Bulk Insert fails. Column is too long in the data file for row 1, column 71. Make sure the field terminator and row terminator are specified correctly.

OLE DB provider 'STREAM' reported an error. The provider did not give any information about the error.
OLE DB error trace [OLE/DB Provider 'STREAM' IRowset::GetNextRows returned 0x80004005: The provider did not give any information about the error.].
The statement has been terminated.
at System.Data.SqlClient.SqlCommand.ExecuteNonQuery()
at Microsoft.Crm.Application.Outlook.OfflineSync.Utility.ExecuteSql(String strCommand, CrmDbConnection dbConnection)
at Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.PopulateTempTable(String tempTableName, String fileName, CrmDbConnection dbConnection, Int32 count, String formatFile)
at Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.DoInsertTable(EntityMetadata entity, String fileName, Int32 count, Boolean extension, String attributes)
at Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.DoInsert(EntityMetadata entity, String fileName, Int32 count)
at Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.ExecuteInsert(String entityName, Int32 count)
at Microsoft.Crm.Application.Outlook.OfflineSync.SyncData.DoBatchStep(ITransferDataProvider transferDataProvider, String entityName, SyncAction action, Int32 batchRows).

CAUSE

This problem may occur when the following conditions are true:
  • You added a custom attribute field that uses the NTEXT type to the main form of an entity.
  • The custom attribute field on a related record contains more than 4,000 characters.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Dynamics CRM 3.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Installation information

Install this hotfix on the laptop client computers that are running the client components of Microsoft Dynamics CRM 3.0.

Prerequisites

There are no prerequisites to apply this hotfix.

Removal information

To remove this hotfix from a computer that is running Microsoft Windows 2000, Microsoft Windows XP, or Microsoft Windows Server 2003, use the Add or Remove Programs item in Control Panel.

System administrators can use the Spuninst.exe utility to remove this hotfix from a computer that is running Windows 2000, Windows XP, or Windows Server 2003. The Spuninst.exe utility is located in the following folder:

%Windir%\$NTUninstallKB918108$\Spuninst

For more information about package installer parameters, click the following article number to view the article in the Microsoft Knowledge Base:

832475 Description of the new features in the package installer for Windows software updates

Restart requirement

If you are prompted, restart the computer after you install the hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTime
Microsoft.crm.application.outlook.offlinesync.dll3.0.5300.1278 80,76028-Aug-200606:42

MORE INFORMATION

For more information about the terminology that is used to describe Microsoft software updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

887283 Microsoft Business Solutions CRM software hotfix and update package naming standards


Modification Type:MajorLast Reviewed:10/9/2006
Keywords:kberrmsg kbBug kbMBScustomization kbHotfixServer kbQFE kbMBSMigrate kbpubtypekc KB918108 kbAudEndUser